aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/linuxconsoletools/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/community/linuxconsoletools/APKBUILD b/community/linuxconsoletools/APKBUILD
new file mode 100644
index 0000000000..ff19b7eec1
--- /dev/null
+++ b/community/linuxconsoletools/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=linuxconsoletools
+pkgver=1.7.0
+pkgrel=0
+pkgdesc="Tools for connecting joysticks & legacy devices to the kernels input subsystem"
+url="https://sourceforge.net/projects/linuxconsole/"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="linux-headers sdl2-dev"
+subpackages="$pkgname-doc"
+source="https://downloads.sourceforge.net/linuxconsole/linuxconsoletools-$pkgver.tar.bz2"
+
+
+build() {
+ make PREFIX=/usr
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+sha512sums="260667e167281dd6f4de0904c2852a5bf3d9d0fe9d603135d4849c5a6610997306c9b476f64e4015d17a4dc8e4a8d36e96e01b9b63664fc7b493201fe12b4f56 linuxconsoletools-1.7.0.tar.bz2"