aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/tinc-pre/APKBUILD32
-rw-r--r--community/tinc-pre/disable-ping-tests.patch11
-rw-r--r--community/tinc-pre/tinc-1.1-fix-paths.patch46
3 files changed, 41 insertions, 48 deletions
diff --git a/community/tinc-pre/APKBUILD b/community/tinc-pre/APKBUILD
index bfc433f358..a7eb3ae751 100644
--- a/community/tinc-pre/APKBUILD
+++ b/community/tinc-pre/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=tinc-pre
-_realver="1.1pre15"
+_realver="1.1pre17"
pkgver=${_realver/pre/.}
-pkgrel=4
+pkgrel=0
pkgdesc="Virtual Private Network (VPN) daemon (pre-release)"
url="http://tinc-vpn.org/"
# s390x: tests hang
@@ -13,10 +13,9 @@ license="GPL-2.0"
makedepends="linux-headers ncurses-dev readline-dev
zlib-dev lzo-dev openssl-dev texinfo
automake autoconf libtool bash"
-subpackages="$pkgname-doc $pkgname-gui::noarch"
+subpackages="$pkgname-doc"
source="http://tinc-vpn.org/packages/tinc-$_realver.tar.gz
tinc-1.1-fix-paths.patch
- disable-ping-tests.patch
$pkgname.initd
$pkgname.confd
$pkgname.networks
@@ -39,11 +38,14 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
- --enable-jumbograms \
- --enable-lzo \
+ --enable-legacy-protocol \
+ --enable-curses \
+ --enable-readline \
--enable-zlib \
- --without-systemd \
- --enable-legacy-protocol
+ --enable-lzo \
+ --disable-miniupnpc \
+ --enable-jumbograms \
+ --without-systemd
make
}
@@ -63,18 +65,8 @@ package() {
"$pkgdir"/etc/conf.d/tinc.networks
}
-gui() {
- # needs wxpython
- pkgdesc="$pkgdesc (Python GUI)"
- depends="python3"
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/tinc-gui \
- "$subpkgdir"/usr/bin/
-}
-
-sha512sums="29b109c84a89204a9fe298e3cfb092169a7c3cbb62e0cabdb7fe8eaa01b03343b7d48bf028525754af1a340781de209e0b9412669c256a30e7226a8a21412c17 tinc-1.1pre15.tar.gz
-55bd0e61a1d10a89d879d5113082f0cdb5ff6bf1d1fb3f618c459eb2658836bf602f72fe27ac03ec78746e300a3a5178db053eef6f08d3cb34b11410dbeb05de tinc-1.1-fix-paths.patch
-8a140f53c1913334ef6b37438c29a53932369b1b82f8196635379041d2c8f0152207cbf5deb5cde9f2052e4fd47c14b3c62bce17de898965dd05af4b9105d99b disable-ping-tests.patch
+sha512sums="b966dbfa522e12ff6766c4deb54a9da29cddc15c3a1df0f0e084df27ee5f1421ffbebc0e29472b1bcd79ea8b41f8c0ef904172e333dcba0b85bafe4654a63b30 tinc-1.1pre17.tar.gz
+bb6f9a1fedf6ffab21f6bfa65c8d977b24453a5d667229eec995b979bbe8dcdaa0617f076a3d9081c4580068b385f7595b80856d5abcf9c928b866eb9c6f4910 tinc-1.1-fix-paths.patch
59811c3e5241d08ebdfbd539556b7cee0dfaab89727ad503512c98f1a696fae143ecdf2682a652c5d71d077ed254ffe2e1c442b1c305c7e7ea94d9af9a1d385e tinc-pre.initd
f8d9354af5ebc07420ced98059262751bffef434b61c6333964338f327e2ac01ae676e375954efa794a1bccf8b939c78387b9fb7261f675f1237b0d946b529c9 tinc-pre.confd
f7cb459c170898e51176bd92c642335386db90b7bca2abb3f6eb2514546efbd74e5fd2c8845060111dd48a0dd2cc1890717a03315c9b86185047c259cdc27135 tinc-pre.networks"
diff --git a/community/tinc-pre/disable-ping-tests.patch b/community/tinc-pre/disable-ping-tests.patch
deleted file mode 100644
index 1e9192b106..0000000000
--- a/community/tinc-pre/disable-ping-tests.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./test/Makefile.am.orig
-+++ ./test/Makefile.am
-@@ -6,8 +6,6 @@
- invite-join.test \
- invite-offline.test \
- invite-tinc-up.test \
-- ns-ping.test \
-- ping.test \
- scripts.test \
- sptps-basic.test \
- variables.test
diff --git a/community/tinc-pre/tinc-1.1-fix-paths.patch b/community/tinc-pre/tinc-1.1-fix-paths.patch
index 519677dd50..9593904042 100644
--- a/community/tinc-pre/tinc-1.1-fix-paths.patch
+++ b/community/tinc-pre/tinc-1.1-fix-paths.patch
@@ -1,42 +1,54 @@
-diff -Naur tinc-1.1pre14.orig/src/names.c tinc-1.1pre14/src/names.c
---- tinc-1.1pre14.orig/src/names.c 2016-04-17 12:08:41.000000000 -0400
-+++ tinc-1.1pre14/src/names.c 2016-10-15 07:37:51.147064396 -0400
-@@ -86,36 +86,11 @@
- if(!pidfilename)
- xasprintf(&pidfilename, "%s" SLASH "pid", confbase);
+diff --git a/src/names.c b/src/names.c
+index 603b536..44064ec 100644
+--- a/src/names.c
++++ b/src/names.c
+@@ -104,47 +104,11 @@ void make_names(bool daemon) {
+ }
+
#else
- bool fallback = false;
+-
- if(daemon) {
-- if(access(LOCALSTATEDIR, R_OK | W_OK | X_OK))
+- if(access(LOCALSTATEDIR, R_OK | W_OK | X_OK)) {
- fallback = true;
+- }
- } else {
- char fname[PATH_MAX];
-- snprintf(fname, sizeof fname, LOCALSTATEDIR SLASH "run" SLASH "%s.pid", identname);
+- snprintf(fname, sizeof(fname), LOCALSTATEDIR SLASH "run" SLASH "%s.pid", identname);
+-
- if(access(fname, R_OK)) {
-- snprintf(fname, sizeof fname, "%s" SLASH "pid", confbase);
-- if(!access(fname, R_OK))
+- snprintf(fname, sizeof(fname), "%s" SLASH "pid", confbase);
+-
+- if(!access(fname, R_OK)) {
- fallback = true;
+- }
- }
- }
-+ if(!logfilename)
-+ xasprintf(&logfilename, "/var/log" SLASH "%s.log", identname);
-
+-
- if(!fallback) {
-- if(!logfilename)
+- if(!logfilename) {
- xasprintf(&logfilename, LOCALSTATEDIR SLASH "log" SLASH "%s.log", identname);
+- }
-
-- if(!pidfilename)
+- if(!pidfilename) {
- xasprintf(&pidfilename, LOCALSTATEDIR SLASH "run" SLASH "%s.pid", identname);
+- }
- } else {
-- if(!logfilename)
+- if(!logfilename) {
- xasprintf(&logfilename, "%s" SLASH "log", confbase);
+- }
-
- if(!pidfilename) {
-- if(daemon)
+- if(daemon) {
- logger(DEBUG_ALWAYS, LOG_WARNING, "Could not access " LOCALSTATEDIR SLASH " (%s), storing pid and socket files in %s" SLASH, strerror(errno), confbase);
+- }
+-
- xasprintf(&pidfilename, "%s" SLASH "pid", confbase);
- }
- }
++ if(!logfilename)
++ xasprintf(&logfilename, "/var/log" SLASH "%s.log", identname);
+
+ if(!pidfilename)
+ xasprintf(&pidfilename, "/run" SLASH "%s.pid", identname);
#endif