aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/bcc/20-install-static.patch8
-rw-r--r--community/bcc/APKBUILD6
2 files changed, 10 insertions, 4 deletions
diff --git a/community/bcc/20-install-static.patch b/community/bcc/20-install-static.patch
index 4c8a305f29..3e56c66098 100644
--- a/community/bcc/20-install-static.patch
+++ b/community/bcc/20-install-static.patch
@@ -1,5 +1,5 @@
diff --git a/src/cc/CMakeLists.txt b/src/cc/CMakeLists.txt
-index c4675dee..e77ae733 100644
+index c4675dee..2bb97395 100644
--- a/src/cc/CMakeLists.txt
+++ b/src/cc/CMakeLists.txt
@@ -145,6 +145,7 @@ if(LIBBPF_FOUND)
@@ -10,3 +10,9 @@ index c4675dee..e77ae733 100644
install(FILES ${bcc_table_headers} DESTINATION include/bcc)
install(FILES ${bcc_api_headers} DESTINATION include/bcc)
install(DIRECTORY ${libbpf_uapi} DESTINATION include/bcc/compat/linux FILES_MATCHING PATTERN "*.h")
+@@ -152,3 +153,5 @@ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libbcc.pc DESTINATION ${CMAKE_INSTALL_
+ endif(ENABLE_CLANG_JIT)
+ install(FILES ${bcc_common_headers} DESTINATION include/bcc)
+ install(TARGETS bccbpf-shared LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
++install(TARGETS bccbpf-static LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
++install(TARGETS bcc-loader-static LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
diff --git a/community/bcc/APKBUILD b/community/bcc/APKBUILD
index b4ecc07e1b..cb86acf932 100644
--- a/community/bcc/APKBUILD
+++ b/community/bcc/APKBUILD
@@ -1,14 +1,14 @@
# Maintainer: Adam Jensen <acjensen@gmail.com>
pkgname=bcc
pkgver=0.12.0
-pkgrel=1
+pkgrel=2
pkgdesc="A toolkit for creating efficient kernel tracing and manipulation programs"
url="https://github.com/iovisor/bcc/"
arch="aarch64 x86 x86_64"
license="Apache-2.0"
# bcc's test suite requires privileged access to run BPF programs
options="!check"
-subpackages="$pkgname-static $pkgname-dev $pkgname-doc:_doc $pkgname-tools:_tools $pkgname-lua:_lua py3-$pkgname:_py"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc:_doc $pkgname-tools:_tools $pkgname-lua:_lua py3-$pkgname:_py:noarch"
_llvmver=9
makedepends="tar git llvm$_llvmver-dev llvm$_llvmver-static clang-dev clang-static cmake
python3 flex-dev bison luajit-dev build-base iperf linux-headers elfutils-dev zlib-dev
@@ -75,4 +75,4 @@ _lua() {
sha512sums="db3ea929b1296f4d9d82d2a11e89e11a1c31512d3f7f935475a7613e0128a5cf9441f3138969535ef41de0c0f677c7446f62f1c64575d41a9896e5339f3f112b bcc-0.12.0.tar.gz
caffeea956f6d4b83f63a321eee17c2a12987c99b3c65444fdfeb15e0f6c8927e865358ed2db6bd6736757df007c4c11bd06a5c174884d1542b7ee38b0496b49 10-use-system-libbpf.patch
-4844295d9468def0c5b896941c002a1cf79ab48aa48e847db9c9e14b392b579be2558e53850fbcdc25124a522be81eb53f2f44b0ef8daa37cd632ec7e57b34a9 20-install-static.patch"
+c84d08f31fceb9af9c4bfeb0056b2f20c385b8eb44aafa1ab40049586e3b71d38882ca236e9f3fff5a9eebae9c570f56c73cc87966659e71743a5a38a30de388 20-install-static.patch"