aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/buildbot/APKBUILD56
-rw-r--r--community/buildbot/buildbot.pre-install6
-rw-r--r--community/buildbot/buildmaster.confd10
-rw-r--r--community/buildbot/buildmaster.initd69
4 files changed, 0 insertions, 141 deletions
diff --git a/community/buildbot/APKBUILD b/community/buildbot/APKBUILD
deleted file mode 100644
index 743275e4f9..0000000000
--- a/community/buildbot/APKBUILD
+++ /dev/null
@@ -1,56 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=buildbot
-pkgver=1.6.0
-pkgrel=0
-pkgdesc="Continuous integration testing framework"
-url="http://buildbot.net/"
-arch="noarch"
-license="GPL-2.0"
-depends="python2 py-twisted py-simplejson py2-sqlalchemy
- py2-pysqlite py-jinja2 py2-sqlalchemy-migrate
- py-dateutil py-setuptools"
-depends_dev=""
-makedepends="python2-dev"
-install="${pkgname}.pre-install"
-BUILDBOT_USER=buildbot
-BUILDBOT_GROUP=buildbot
-pkgusers="$BUILDBOT_USER"
-pkggroups="$BUILDBOT_GROUP"
-subpackages="$pkgname-openrc"
-source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-${pkgver/_/}.tar.gz
- buildmaster.initd
- buildmaster.confd"
-
-builddir="$srcdir"/$pkgname-${pkgver/_/}
-
-check() {
- cd "$builddir"
- python2 setup.py check
-}
-
-prepare() {
- default_prepare
-}
-
-build() {
- cd "$builddir"
- python2 setup.py build
-}
-
-package() {
- cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
- install -D -m 755 \
- "$srcdir"/buildmaster.initd \
- "$pkgdir"/etc/init.d/buildmaster
- install -D -m 644 \
- "$srcdir"/buildmaster.confd \
- "$pkgdir"/etc/conf.d/buildmaster
- install -d -o $BUILDBOT_USER -g $BUILDBOT_GROUP \
- "$pkgdir"/var/lib/buildmaster
-}
-
-sha512sums="1d54bf5b0932b8bb21e0c6a8b8545eccfa48af56dd751d97ab9f8540c0e1735dc98871b33616ba66467f7ca78d2c54c3d6666264784d236097659f3f4d1fd5f0 buildbot-1.6.0.tar.gz
-2e65d22f1b94433ba11839fb3434d072f9ff8132396b03fdcdb3b437778679d1699534296fbb851d2661a3a7a0bce4ef1f94c49e7910419557e4055f2ed1a4d5 buildmaster.initd
-d9339c30d3a92e92b41b0e3139ec89ecbd1460b0e4ee6c6fe2560c4307b2eb3f29b838c2f2312b9c7049bd95eaf652d09039227c691af805bc25a36999ec1840 buildmaster.confd"
diff --git a/community/buildbot/buildbot.pre-install b/community/buildbot/buildbot.pre-install
deleted file mode 100644
index 7a1deeded1..0000000000
--- a/community/buildbot/buildbot.pre-install
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-addgroup -S buildbot 2>/dev/null
-adduser -S -D -H -h /home/buildbot -s /sbin/nologin -G buildbot -g buildbot buildbot 2>/dev/null
-
-exit 0
diff --git a/community/buildbot/buildmaster.confd b/community/buildbot/buildmaster.confd
deleted file mode 100644
index e489d66f9d..0000000000
--- a/community/buildbot/buildmaster.confd
+++ /dev/null
@@ -1,10 +0,0 @@
-
-# Path to the build master's basedir.
-BASEDIR=/var/lib/buildmaster
-
-# User account for the buildmaster.
-# The basedir should be owned by this user.
-USERNAME=buildbot
-
-# Extra options to pass to twistd.
-TWISTD_OPTS=""
diff --git a/community/buildbot/buildmaster.initd b/community/buildbot/buildmaster.initd
deleted file mode 100644
index 05c1a10104..0000000000
--- a/community/buildbot/buildmaster.initd
+++ /dev/null
@@ -1,69 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-extra_started_commands="reload"
-extra_stopped_commands="create"
-
-depend() {
- need net
-}
-
-checkconfig() {
- if [ -z "${BASEDIR}" ]; then
- eerror "BASEDIR not set"
- return 1
- fi
- if [ -z "${USERNAME}" ]; then
- eerror "USERNAME not set"
- return 1
- fi
- if [ ! -d "${BASEDIR}" ]; then
- eerror "${BASEDIR} is not a directory"
- return 1
- fi
- if [ ! -e "${BASEDIR}/buildbot.tac" ]; then
- eerror "${BASEDIR} does not contain buildbot.tac"
- return 1
- fi
-}
-
-start() {
- checkconfig || return 1
- ebegin "Starting buildmaster in ${BASEDIR}"
- start-stop-daemon --start -u "${USERNAME}" \
- --pidfile "${BASEDIR}/buildmaster.pid" \
- --exec /usr/bin/python -- /usr/bin/twistd \
- --no_save \
- --logfile="${BASEDIR}/twistd.log" \
- --pidfile="${BASEDIR}/buildmaster.pid" \
- --python="${BASEDIR}/buildbot.tac"
- eend $?
-}
-
-stop() {
- ebegin "Stopping buildmaster in ${BASEDIR}"
- start-stop-daemon --stop --pidfile "${BASEDIR}/buildmaster.pid"
- eend $?
-}
-
-reload() {
- ebegin "Reconfiguring buildmaster in ${BASEDIR}"
- start-stop-daemon --signal HUP --pidfile \
- "${BASEDIR}"/buildmaster.pid
- eend $?
-}
-
-create() {
- if [ -e "${BASEDIR}"/buildbot.tac -o -e "${BASEDIR}"/master.cfg ]; then
- eerror "${BASEDIR} already contains buildbot.tac or master.cfg"
- return 1
- fi
- ebegin "Creating buildmaster in ${BASEDIR}"
- start-stop-daemon -u "${USERNAME}" \
- --exec /usr/bin/buildbot \
- -- create-master -r "${BASEDIR}"
- mv "${BASEDIR}"/master.cfg.sample "${BASEDIR}"/master.cfg
- ewarn "Remember to customize exemplary master.cfg in ${BASEDIR}"
- eend $?
-}