aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/php7-pecl-apcu/APKBUILD (renamed from community/php7-apcu/APKBUILD)14
1 files changed, 8 insertions, 6 deletions
diff --git a/community/php7-apcu/APKBUILD b/community/php7-pecl-apcu/APKBUILD
index 4aa24569e4..47165013d5 100644
--- a/community/php7-apcu/APKBUILD
+++ b/community/php7-pecl-apcu/APKBUILD
@@ -1,18 +1,20 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
-pkgname=php7-apcu
+pkgname=php7-pecl-apcu
_pkgreal=apcu
# release 5 is php7+
pkgver=5.1.12
-pkgrel=1
-pkgdesc="PHP extension APC User Cache"
+pkgrel=2
+pkgdesc="PHP extension APC User Cache - PECL"
url="https://pecl.php.net/package/apcu"
arch="all"
-license="PHP"
-depends=""
-makedepends="pcre-dev php7-dev autoconf"
+license="PHP-3.01"
+depends="php7-common"
+makedepends="pcre-dev php7-dev autoconf re2c"
source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
builddir="$srcdir/$_pkgreal-$pkgver"
+provides="php7-apcu=$pkgver-r$pkgrel" # for backward compatibility
+replaces="php7-apcu" # for backward compatibility
build() {
cd "$builddir"