aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/osinfo-db-tools/APKBUILD33
1 files changed, 22 insertions, 11 deletions
diff --git a/community/osinfo-db-tools/APKBUILD b/community/osinfo-db-tools/APKBUILD
index 3af4a9c65e..5720d124b5 100644
--- a/community/osinfo-db-tools/APKBUILD
+++ b/community/osinfo-db-tools/APKBUILD
@@ -1,22 +1,24 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=osinfo-db-tools
-pkgver=1.1.0
+pkgver=1.5.0
pkgrel=0
pkgdesc="Tools for managing the osinfo database"
-url="http://libosinfo.org/"
+url="https://libosinfo.org/"
arch="all"
license="GPL-2.0-or-later"
-depends=""
-depends_dev=""
-makedepends="$depends_dev intltool glib-dev libxml2-dev libarchive-dev
- libxslt-dev"
-install=""
+makedepends="intltool glib-dev libxml2-dev libarchive-dev libxslt-dev json-glib-dev
+ automake autoconf libtool"
+checkdepends="py3-pytest py3-requests"
subpackages="$pkgname-doc $pkgname-lang"
source="https://releases.pagure.org/libosinfo/osinfo-db-tools-$pkgver.tar.gz"
-builddir="$srcdir/osinfo-db-tools-$pkgver"
+
+prepare() {
+ default_prepare
+ autoreconf -fi
+}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,9 +29,18 @@ build() {
make
}
+check() {
+ # One of the tests run a user instance of osinfo-db-tools which
+ # installs configuration to the value of $XDG_CONFIG_HOME, defaulting
+ # to $HOME/.config as per the XDG standard. But the value might be changed
+ # by the user and the test only checks for $HOME/.config. So unset it here
+ # so it doesn't have a chance to fail.
+ unset XDG_CONFIG_HOME
+ make check
+}
+
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="52e08e67b75fb84c7d7721dd76f1bf09f71c27deffc4d8391234aec939863de4e96cbd8fc9783944b2493fef183518a21ff185ec5a5d9934adc6d3c67bf0f972 osinfo-db-tools-1.1.0.tar.gz"
+sha512sums="baa42086ae13365e463064f0313228ec79d785a863b72c396d2a24d35496420d17ea09191629663c8c67ec46f3168f256ff50896053244cd0255be6ac08583d1 osinfo-db-tools-1.5.0.tar.gz"