aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/lmdb/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/community/lmdb/APKBUILD b/community/lmdb/APKBUILD
index ccf9ca2a27..76b7710329 100644
--- a/community/lmdb/APKBUILD
+++ b/community/lmdb/APKBUILD
@@ -2,11 +2,11 @@
# Maintainer:
pkgname=lmdb
pkgver=0.9.21
-pkgrel=1
+pkgrel=2
pkgdesc="Lightning Memory-Mapped Database"
url="http://symas.com/mdb/"
arch="all"
-license="custom"
+license="OLDAP-2.8"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="https://github.com/LMDB/lmdb/archive/LMDB_$pkgver.tar.gz
lmdb_make.patch"
@@ -14,12 +14,17 @@ builddir="$srcdir/$pkgname-LMDB_$pkgver/libraries/liblmdb"
build() {
cd "$builddir"
- make || return 1
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
tools() {