aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/astyle/APKBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/community/astyle/APKBUILD b/community/astyle/APKBUILD
index 56b561887b..dc2c9dd592 100644
--- a/community/astyle/APKBUILD
+++ b/community/astyle/APKBUILD
@@ -1,29 +1,24 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=astyle
pkgver=3.1
-pkgrel=1
+pkgrel=2
pkgdesc="An automatic code formatter"
-url="http://sourceforge.net/projects/astyle"
+options="!check" # No testsuite
+url="https://sourceforge.net/projects/astyle/"
arch="all"
-license="LGPL"
+license="MIT"
source="https://downloads.sourceforge.net/sourceforge/astyle/${pkgname}_${pkgver}_linux.tar.gz
-fix-ppc64le-build.patch"
+ fix-ppc64le-build.patch"
builddir="$srcdir/$pkgname"
build() {
- cd "$builddir/build/gcc"
+ cd build/gcc
make release
}
-check() {
- cd "$builddir/build/gcc"
- # upstream do not provide tests
- ./bin/astyle --version
-}
-
package() {
- cd "$builddir/build/gcc"
+ cd build/gcc
install -Dm0755 bin/astyle "$pkgdir/usr/bin/astyle"
}