aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/rawtherapee/APKBUILD33
-rw-r--r--community/rawtherapee/gcc6.patch11
2 files changed, 26 insertions, 18 deletions
diff --git a/community/rawtherapee/APKBUILD b/community/rawtherapee/APKBUILD
index 4bdd393856..7be9e08670 100644
--- a/community/rawtherapee/APKBUILD
+++ b/community/rawtherapee/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=rawtherapee
pkgver=4.2
-pkgrel=1
+pkgrel=2
pkgdesc="RawTherapee is image processing software simular to Lightroom or Aperture"
url="http://rawtherapee.com"
arch="x86 x86_64"
@@ -18,37 +18,34 @@ subpackages="$pkgname-doc"
source="http://rawtherapee.com/shared/source/${pkgname}-${pkgver}.tar.xz
sigc++.patch
c++11.patch
+ gcc6.patch
"
-_builddir=${srcdir}/${pkgname}-${pkgver}
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir=${srcdir}/${pkgname}-${pkgver}
build() {
- cd "$_builddir"
+ mkdir -p "$builddir"/build
+ cd "$builddir"/build
export CXXFLAGS="$CXXFLAGS -std=c++11"
- cmake -DCMAKE_INSTALL_PREFIX=/usr || return 1
- make
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ .. || return 1
+ make || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"/build
make DESTDIR="$pkgdir" install
}
md5sums="e6510ed56fdc35aa712b4c0f54c52ac0 rawtherapee-4.2.tar.xz
63dc8bf5dd7468a12fba75805fb6520d sigc++.patch
-5fa63cca42b2af2cd6cddab3e8dfd786 c++11.patch"
+5fa63cca42b2af2cd6cddab3e8dfd786 c++11.patch
+acf576a2e18fb92f1249db662ec74dd8 gcc6.patch"
sha256sums="fa4c13e8842df096b19d2dabaed5a61f5f9d4547f7b4f0dc6b77f80bdec16479 rawtherapee-4.2.tar.xz
d57361e6bdb0386ca84b4c25b7aed0b4b6659035f72178a6f8cb6f9031672c90 sigc++.patch
-9a63bd8d0c0149bf48e33441b5f0e2c163bfcd9c3204a6d353c054eb69e7bcb6 c++11.patch"
+9a63bd8d0c0149bf48e33441b5f0e2c163bfcd9c3204a6d353c054eb69e7bcb6 c++11.patch
+b5c9e8fa56bc690215c0eb7e2c26de59a928fb532d5e339d35a070ae4a011815 gcc6.patch"
sha512sums="feec61aeb84804cf01ff03fa9d7309f0eb3c04c43818c8397cc6f3ee762aca19484bce7594414d2141248b9740bdd4269fd86f76dcf391c61d4647fa169d48f6 rawtherapee-4.2.tar.xz
bce6c8b1f02ff335ef10fff7decc61f21c5c8cea251fe703d9fc50616d3113f0439cd05b06aa698849f4356afa63ddf19d0a5d2f39df7ff73406a3e243cafb09 sigc++.patch
-81a403b999e5aa9e2e91445734950ac01de7daab3c21569cad78c7bb54d43e7db9340320e556d8bc3f12c4903bc66852e17306e3b73e0744d02d7c2ff32ad239 c++11.patch"
+81a403b999e5aa9e2e91445734950ac01de7daab3c21569cad78c7bb54d43e7db9340320e556d8bc3f12c4903bc66852e17306e3b73e0744d02d7c2ff32ad239 c++11.patch
+94f5939175cf22712c886ff7d2069f02c81a14e5ccdff73496605c837f56b6960252fa9ee7ca390990cb49382f7fbf8d242f361ed2044ef33d250796b5656e02 gcc6.patch"
diff --git a/community/rawtherapee/gcc6.patch b/community/rawtherapee/gcc6.patch
new file mode 100644
index 0000000000..b4ee6126a6
--- /dev/null
+++ b/community/rawtherapee/gcc6.patch
@@ -0,0 +1,11 @@
+--- ./rtexif/rtexif.h.orig
++++ ./rtexif/rtexif.h
+@@ -410,7 +410,7 @@
+ else
+ lensAperture = exp( log(a1)+(log(a2)-log(a1))/(log(f2)-log(f1))*(log(focalLength)-log(f1)) );
+
+- dif = abs(lensAperture - maxApertureAtFocal);
++ dif = std::abs(lensAperture - maxApertureAtFocal);
+ }else
+ dif = 0;
+ if( dif < deltaMin ){