aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/greenbone-security-assistant/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/community/greenbone-security-assistant/APKBUILD b/community/greenbone-security-assistant/APKBUILD
index 0e4970c1a8..5a8de841fa 100644
--- a/community/greenbone-security-assistant/APKBUILD
+++ b/community/greenbone-security-assistant/APKBUILD
@@ -4,14 +4,15 @@ pkgname=greenbone-security-assistant
_pkgname=gsad
pkgver=7.0.2
_pkgid=2429
-pkgrel=4
+pkgrel=5
pkgdesc="Greenbone Security Assistant (gsa) - OpenVAS web frontend"
url="http://www.openvas.org/"
arch="all"
license="GPL"
depends="wget"
makedepends="cmake doxygen xmltoman openvas-libraries-dev
- libxslt-dev libmicrohttpd-dev"
+ libxslt-dev libmicrohttpd-dev py-polib"
+checkdepends="cppcheck"
subpackages="$pkgname-doc"
source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz
$_pkgname.initd
@@ -31,7 +32,12 @@ build() {
-DSYSCONFDIR=/etc \
-DSBINDIR=/usr/sbin \
-DLOCALSTATEDIR=/var .
- make || return 1
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {