aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/libinput/APKBUILD35
-rw-r--r--community/sway/APKBUILD46
-rw-r--r--community/wayland-protocols/APKBUILD36
-rw-r--r--community/wlc/APKBUILD36
4 files changed, 153 insertions, 0 deletions
diff --git a/community/libinput/APKBUILD b/community/libinput/APKBUILD
new file mode 100644
index 0000000000..46379e84a6
--- /dev/null
+++ b/community/libinput/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
+pkgname=libinput
+pkgver=1.6.3
+pkgrel=0
+pkgdesc="Library for handling input devices"
+url="http://www.freedesktop.org/wiki/Software/libinput/"
+arch="all"
+license="custom"
+depends=""
+makedepends="mtdev-dev eudev-dev libevdev-dev grep"
+subpackages="$pkgname-dev $pkgname-doc"
+options="!check"
+source="http://freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz"
+
+builddir="$srcdir/$pkgname-$pkgver"
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-libwacom \
+ || return 1
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" -C "$builddir" install
+}
+
+sha512sums="be1ab191b5605943d6f46a5fee7af9ecba83ab30ba3d38b6ec136980f2183f6dcb5aaf048aa81a096c4f51b6de05bebc83b4ffa29a0574752062a994f377aa5f libinput-1.6.3.tar.xz"
diff --git a/community/sway/APKBUILD b/community/sway/APKBUILD
new file mode 100644
index 0000000000..dcd7fd45e3
--- /dev/null
+++ b/community/sway/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
+pkgname=sway
+pkgver=0.12
+pkgrel=1
+pkgdesc="i3 compatible window manager for Wayland"
+url="http://swaywm.org"
+arch="all"
+license="MIT"
+options="suid !check"
+depends=""
+makedepends="asciidoc cmake gdk-pixbuf json-c-dev libcap-dev libinput-dev
+ linux-pam-dev pango-dev wayland-dev wlc-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/SirCmpwn/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ sed -i 's/login/base-auth/g' swaylock/pam/swaylock
+}
+
+build() {
+ cd "$builddir"
+ cmake . \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ || return 1
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir/" install || return 1
+
+ chmod u+s "$pkgdir"/usr/bin/sway || return 1
+
+ local i; for i in 1 5 7; do
+ install -Dm644 bin/*.$i \
+ "$pkgdir"/usr/share/man/man$i/ || return 1
+ done
+}
+
+sha512sums="2e0d2ea04752469814b177badfb698fdd2fe2f9fe02ad543fbda337a68501838590def156f8bc3d0e958f0e14fb122cda019c6a20b5f342edc2a78b1d177f3a0 sway-0.12.tar.gz"
diff --git a/community/wayland-protocols/APKBUILD b/community/wayland-protocols/APKBUILD
new file mode 100644
index 0000000000..9432fd7803
--- /dev/null
+++ b/community/wayland-protocols/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+pkgname=wayland-protocols
+pkgver=1.7
+pkgrel=3
+pkgdesc="Protocols and protocol extensions complementing the Wayland core protocol"
+url="http://wayland.freedesktop.org"
+arch="noarch"
+license="MIT"
+depends=
+provides="$pkgname-dev"
+makedepends="wayland-dev"
+subpackages=
+options="!check"
+source="https://wayland.freedesktop.org/releases/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ make DESTDIR="$pkgdir" \
+ -C "$builddir" install || return 1
+}
+
+sha512sums="291a3226cc538de3b81bdffa5de513b305a946bfc3481e21c254fcc6a023e0cf2ff1869509c7ae193da02460f1d4a3c5cd5f1ca13b2550886acffcc636fb30d2 wayland-protocols-1.7.tar.xz"
diff --git a/community/wlc/APKBUILD b/community/wlc/APKBUILD
new file mode 100644
index 0000000000..34158ba454
--- /dev/null
+++ b/community/wlc/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
+pkgname=wlc
+pkgver=0.0.8
+pkgrel=1
+pkgdesc="Wayland Compositor Library"
+url="https://github.com/Cloudef/wlc"
+arch="all"
+license="MIT"
+depends="xkeyboard-config"
+makedepends="cmake eudev-dev libinput-dev libx11-dev libxkbcommon-dev mesa-dev
+ pixman-dev wayland-dev wayland-protocols xcb-util-image-dev
+ xcb-util-wm-dev"
+subpackages="$pkgname-dev"
+source="https://github.com/Cloudef/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ cmake . \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ || return 1
+ make
+}
+
+check() {
+ make test -C "$builddir"
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C "$builddir" install
+}
+
+sha512sums="5ddf7dfc5115fa51ea078933b60c6e8ef9515db98f1c47d4ecfe3f49e07dbdadf2bbeb6f6002cc83d13098dee5fa7e66fcae211a58bd762ee984088aebadb779 wlc-0.0.8.tar.bz2"