aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/libfm/APKBUILD19
-rw-r--r--community/pcmanfm/APKBUILD11
-rw-r--r--community/pcmanfm/CVE-2017-8934.patch56
3 files changed, 16 insertions, 70 deletions
diff --git a/community/libfm/APKBUILD b/community/libfm/APKBUILD
index 1eda7a4763..20a1d6db69 100644
--- a/community/libfm/APKBUILD
+++ b/community/libfm/APKBUILD
@@ -2,17 +2,22 @@
# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
pkgname=libfm
-pkgver=1.2.5
-pkgrel=1
+pkgver=1.3.0.2
+pkgrel=0
pkgdesc="Library for file management"
url="https://wiki.lxde.org/en/PCManFM"
arch="all"
-license="GPL-2.0+"
+license="GPL-2.0-or-later"
makedepends="gtk+2.0-dev menu-cache-dev udisks-dev intltool dbus-glib-dev
- libexif-dev"
+ libexif-dev vala gtk-doc automake autoconf libtool"
options="libtool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="http://downloads.sourceforge.net/pcmanfm/$pkgname-$pkgver.tar.xz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/lxde/$pkgname/archive/$pkgver.tar.gz
+ "
+prepare() {
+ cd "$builddir"
+ ./autogen.sh
+}
build() {
cd "$builddir"
@@ -37,6 +42,4 @@ package() {
mv "$pkgdir"/usr/include/libfm-1.0/ "$pkgdir"/usr/include/libfm
}
-md5sums="a1ba9ae5e920f38b647dd511edd6c807 libfm-1.2.5.tar.xz"
-sha256sums="c706bb1020cf5f2d6f5a9226f692ce1985947134dcf2bde64278bd0420779b5a libfm-1.2.5.tar.xz"
-sha512sums="14630639dab9289f1a4c30eaf0f1b628ff0d492c095ce31c15e1dcacfd12d5a91551fecb67bd6d949fbc0c3f16850352b699e86dd200cda92da45539b7e87074 libfm-1.2.5.tar.xz"
+sha512sums="c954c7210b6eee66ec265490e16fe91fe7995cd95b340f49197eec60a9af94f1ca0f67861dd5455c0deb81a10f5091cbf3dc471ed224477acdc081b48d036c69 libfm-1.3.0.2.tar.gz"
diff --git a/community/pcmanfm/APKBUILD b/community/pcmanfm/APKBUILD
index 9a0f435000..811d15e79a 100644
--- a/community/pcmanfm/APKBUILD
+++ b/community/pcmanfm/APKBUILD
@@ -2,16 +2,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pcmanfm
-pkgver=1.2.5
-pkgrel=2
+pkgver=1.3.0
+pkgrel=0
pkgdesc="Extremely fast and lightweight file manager"
arch="all"
url="https://wiki.lxde.org/en/PCManFM"
-license="GPL-2.0+"
+license="GPL-2.0-or-later"
makedepends="gtk+2.0-dev libfm-dev intltool"
subpackages="$pkgname-doc $pkgname-lang"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.xz
- CVE-2017-8934.patch"
+ "
# secfixes:
# 1.2.5-r1:
@@ -39,5 +39,4 @@ package() {
"$pkgdir"/usr/share/applications/pcmanfm.desktop
}
-sha512sums="ce53315483f58361c5a7797bdca355dbbedc2cf3907d319c7c65be844ea74ed297497dc3183c903e06b8294f6301d19347f6b9871e34bf773c04ff4fb8ab32f3 pcmanfm-1.2.5.tar.xz
-31c669e61832c1144dac7ef619b8dcdef7ee43f3f40e874695bef6aecc81d53caabb66913ea96ed5c2f5d79ac9bb5379ef317d9428bef837013c18d24da7536e CVE-2017-8934.patch"
+sha512sums="022e6e203a6cbba6531eb3dd21e0dd96687c42992015225f979a8df4539ddb0071f70d8619a7d804c0399424833af20181b8473a35a14b0fa1653e6fdbdfa367 pcmanfm-1.3.0.tar.xz"
diff --git a/community/pcmanfm/CVE-2017-8934.patch b/community/pcmanfm/CVE-2017-8934.patch
deleted file mode 100644
index 489d22c83b..0000000000
--- a/community/pcmanfm/CVE-2017-8934.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From bc8c3d871e9ecc67c47ff002b68cf049793faf08 Mon Sep 17 00:00:00 2001
-From: Andriy Grytsenko <andrej@rep.kiev.ua>
-Date: Sun, 14 May 2017 21:35:40 +0300
-Subject: [PATCH] Fix potential access violation, use runtime user dir instead
- of tmp dir.
-
----
- NEWS | 4 ++++
- src/single-inst.c | 7 ++++++-
- 2 files changed, 10 insertions(+), 1 deletion(-)
-
-diff --git a/NEWS b/NEWS
-index 8c2049a..876f7f3 100644
---- a/NEWS
-+++ b/NEWS
-@@ -1,3 +1,7 @@
-+* Fixed potential access violation, use runtime user dir instead of tmp dir
-+ for single instance socket.
-+
-+
- Changes on 1.2.5 since 1.2.4:
-
- * Removed options to Cut, Remove and Rename from context menu on mounted
-diff --git a/src/single-inst.c b/src/single-inst.c
-index 62c37b3..aaf84ab 100644
---- a/src/single-inst.c
-+++ b/src/single-inst.c
-@@ -2,7 +2,7 @@
- * single-inst.c: simple IPC mechanism for single instance app
- *
- * Copyright 2010 Hong Jen Yee (PCMan) <pcman.tw@gmail.com>
-- * Copyright 2012 Andriy Grytsenko (LStranger) <andrej@rep.kiev.ua>
-+ * Copyright 2012-2017 Andriy Grytsenko (LStranger) <andrej@rep.kiev.ua>
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
-@@ -404,11 +404,16 @@ static void get_socket_name(SingleInstData* data, char* buf, int len)
- }
- else
- dpynum = 0;
-+#if GLIB_CHECK_VERSION(2, 28, 0)
-+ g_snprintf(buf, len, "%s/%s-socket-%s-%d", g_get_user_runtime_dir(),
-+ data->prog_name, host ? host : "", dpynum);
-+#else
- g_snprintf(buf, len, "%s/.%s-socket-%s-%d-%s",
- g_get_tmp_dir(),
- data->prog_name,
- host ? host : "",
- dpynum,
- g_get_user_name());
-+#endif
- }
-
---
-2.1.4
-