aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/ocaml-lablgtk/APKBUILD9
-rw-r--r--community/ocaml-lablgtk/ignore-warnings.patch23
2 files changed, 28 insertions, 4 deletions
diff --git a/community/ocaml-lablgtk/APKBUILD b/community/ocaml-lablgtk/APKBUILD
index ec59b165f2..fb0f46ddce 100644
--- a/community/ocaml-lablgtk/APKBUILD
+++ b/community/ocaml-lablgtk/APKBUILD
@@ -6,8 +6,7 @@ pkgver=2.18.6
pkgrel=0
pkgdesc="An OCaml interface to GTK+ 2.x"
url="http://lablgtk.forge.ocamlcore.org/"
-# arch="all !x86 !armhf !armv7 !s390x" # limited by ocaml aport
-arch="" # Fails on all builders
+arch="all !x86 !armhf !armv7 !s390x" # limited by ocaml aport
license="LGPL-2.1-only-WITH-linking-exception"
depends="ocaml-runtime"
depends_dev="$pkgname=$pkgver-r$pkgrel
@@ -17,7 +16,8 @@ makedepends="$depends_dev ocaml ocaml-compiler-libs ocaml-ocamldoc
replaces="lablgtk"
provides="lablgtk=$pkgver-r$pkgrel" # for backward compatibility
subpackages="$pkgname-dev"
-source="https://forge.ocamlcore.org/frs/download.php/1726/$_pkgname-$pkgver.tar.gz"
+source="https://forge.ocamlcore.org/frs/download.php/1726/$_pkgname-$pkgver.tar.gz
+ ignore-warnings.patch"
builddir="$srcdir/$_pkgname-$pkgver"
options="!check textrels"
@@ -32,4 +32,5 @@ package() {
rm -f "$pkgdir"/usr/lib/ocaml/ld.conf
}
-sha512sums="0d30da0e4a93b1693ac6d63161d40c8cd6d9337e105a65f3cc01b013ce7ca04aa5e1a013527cb0728a9b7b7af20d0f4c8b0cc7f9102e553dff3cf8bc83a14e5e lablgtk-2.18.6.tar.gz"
+sha512sums="0d30da0e4a93b1693ac6d63161d40c8cd6d9337e105a65f3cc01b013ce7ca04aa5e1a013527cb0728a9b7b7af20d0f4c8b0cc7f9102e553dff3cf8bc83a14e5e lablgtk-2.18.6.tar.gz
+c9a5eb20cd38a8e5783caca83ea1ee5abb011e02e9c49b3ae70bb423bd90e1197dfa56c339191c05691babbb47976a953b8f8392c2a1b9a2ff5e8b0b4632b9a1 ignore-warnings.patch"
diff --git a/community/ocaml-lablgtk/ignore-warnings.patch b/community/ocaml-lablgtk/ignore-warnings.patch
new file mode 100644
index 0000000000..b829097ce3
--- /dev/null
+++ b/community/ocaml-lablgtk/ignore-warnings.patch
@@ -0,0 +1,23 @@
+Without this patch Lablgtk treats warnings as errors.
+
+This causes the build to fail with our currently packed ocaml version:
+
+ File "gdk.ml", line 346, characters 2-55:
+ 346 | external create : len:int -> t = "ml_point_array_new"
+ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
+ Error (warning 61): This primitive declaration uses type t, which is unannotated and
+ unboxable. The representation of such types may change in future
+ versions. You should annotate the declaration of t with [@@boxed]
+ or [@@unboxed].
+
+diff -upr lablgtk-2.18.6.orig/src/Makefile lablgtk-2.18.6/src/Makefile
+--- lablgtk-2.18.6.orig/src/Makefile 2019-12-05 13:29:04.763064450 +0100
++++ lablgtk-2.18.6/src/Makefile 2019-12-05 13:29:20.569735224 +0100
+@@ -1,6 +1,6 @@
+ # Makefile for lablgtk.
+
+-COMPILER = $(CAMLC) $(MLFLAGS) $(MLBYTEFLAGS) -w s-3+52 -warn-error A-52 -c
++COMPILER = $(CAMLC) $(MLFLAGS) $(MLBYTEFLAGS) -w s-3+52 -c
+ LINKER = $(CAMLC) $(MLFLAGS) $(MLBYTEFLAGS)
+ COMPOPT = $(CAMLOPT) $(MLFLAGS) -w s -c
+ LINKOPT = $(CAMLOPT) $(MLFLAGS)