aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/xfce4-xkb-plugin/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/xfce4-xkb-plugin/APKBUILD b/community/xfce4-xkb-plugin/APKBUILD
new file mode 100644
index 0000000000..3182bcb22b
--- /dev/null
+++ b/community/xfce4-xkb-plugin/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-xkb-plugin
+pkgver=0.8.1
+_maj=${pkgver%%.*}
+_min=${pkgver#${_maj}.}
+_min=${_min%%.*}
+_ver=${_maj}.${_min}
+pkgrel=0
+pkgdesc="plugin to switch keyboard layouts for the Xfce4 panel"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-xkb-plugin"
+arch="all"
+license="custom"
+options="!check" # No test suite
+depends=""
+makedepends="xfce4-panel-dev libxklavier-dev librsvg-dev intltool libwnck3-dev
+ libxi-dev libxkbfile-dev libsm-dev libgsf-dev e2fsprogs-dev bzip2-dev
+ libxfce4ui-dev garcon-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-xkb-plugin/$_ver/xfce4-xkb-plugin-$pkgver.tar.bz2"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build () {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+sha512sums="4f0362f429489d111544126697880cdb0a768533803a104f73802fe2c5cfbef5efbf6edd658dbb0ef788ae2a3761f1877c191637a6a06d4a5159bc8f71ad524f xfce4-xkb-plugin-0.8.1.tar.bz2"