aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/ruby-rspec-core/APKBUILD41
-rw-r--r--community/ruby-rspec-core/gemspec.patch16
-rw-r--r--community/ruby-rspec-expectations/APKBUILD40
-rw-r--r--community/ruby-rspec-expectations/gemspec.patch12
-rw-r--r--community/ruby-rspec-mocks/APKBUILD40
-rw-r--r--community/ruby-rspec-mocks/gemspec.patch12
-rw-r--r--community/ruby-rspec-support/APKBUILD40
-rw-r--r--community/ruby-rspec-support/gemspec.patch12
-rw-r--r--community/ruby-rspec/APKBUILD43
-rw-r--r--community/ruby-rspec/gemspec.patch14
10 files changed, 270 insertions, 0 deletions
diff --git a/community/ruby-rspec-core/APKBUILD b/community/ruby-rspec-core/APKBUILD
new file mode 100644
index 0000000000..c7539aab9f
--- /dev/null
+++ b/community/ruby-rspec-core/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ruby-rspec-core
+_gemname=${pkgname#ruby-}
+pkgver=3.7.0
+pkgrel=0
+pkgdesc="RSpec runner and formatters"
+url="https://relishapp.com/rspec/rspec-core/"
+arch="noarch"
+license="MIT"
+depends="ruby ruby-rspec-support>=${pkgver%.*}.0"
+options="!check" # rspec's tests are written in rspec
+source="$pkgname-$pkgver.tar.gz::https://github.com/rspec/$_gemname/archive/v$pkgver.tar.gz
+ gemspec.patch"
+builddir="$srcdir/$_gemname-$pkgver"
+
+build() {
+ cd "$builddir"
+ gem build $_gemname.gemspec
+}
+
+package() {
+ local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+
+ cd "$builddir"
+ gem install --local \
+ --install-dir "$gemdir" \
+ --bindir "$pkgdir/usr/bin" \
+ --ignore-dependencies \
+ --no-document \
+ --verbose \
+ $_gemname
+
+ # Clean-up...
+ rm -r "$gemdir"/cache \
+ "$gemdir"/build_info \
+ "$gemdir"/doc
+}
+
+sha512sums="071bd2a5c905d4ce621f2d7255b882a9d34cf42001cb2995fdb05a91387805929198c32e53cf4c2df2a43d179d2c49337214066be87eb50ab044b5f70aba8c54 ruby-rspec-core-3.7.0.tar.gz
+e0cbcfddcc4c73d9b9673907e3b1a785b399c0b3b213761e9dbca9fadc55d50a88389eaf561f5603bd674eb94ce9f2ecf829d884eaa77df8ef1b565c0c7f25f2 gemspec.patch"
diff --git a/community/ruby-rspec-core/gemspec.patch b/community/ruby-rspec-core/gemspec.patch
new file mode 100644
index 0000000000..0a6cad0d0e
--- /dev/null
+++ b/community/ruby-rspec-core/gemspec.patch
@@ -0,0 +1,16 @@
+--- a/rspec-core.gemspec
++++ b/rspec-core.gemspec
+@@ -13,11 +13,10 @@
+ s.summary = "rspec-core-#{RSpec::Core::Version::STRING}"
+ s.description = "BDD for Ruby. RSpec runner and example groups."
+
+- s.files = `git ls-files -- lib/*`.split("\n")
+- s.files += %w[README.md LICENSE.md Changelog.md .yardopts .document]
++ s.files = Dir["lib/**/*"]
+ s.test_files = []
+ s.bindir = 'exe'
+- s.executables = `git ls-files -- exe/*`.split("\n").map{ |f| File.basename(f) }
++ s.executables = Dir["exe/*"].map{ |f| File.basename(f) }
+ s.rdoc_options = ["--charset=UTF-8"]
+ s.require_path = "lib"
+
diff --git a/community/ruby-rspec-expectations/APKBUILD b/community/ruby-rspec-expectations/APKBUILD
new file mode 100644
index 0000000000..b46c04ab8d
--- /dev/null
+++ b/community/ruby-rspec-expectations/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ruby-rspec-expectations
+_gemname=${pkgname#ruby-}
+pkgver=3.7.0
+pkgrel=0
+pkgdesc="Provides a readable API to express expected outcomes of a code example in RSpec"
+url="https://relishapp.com/rspec/rspec-expectations/"
+arch="noarch"
+license="MIT"
+depends="ruby ruby-diff-lcs ruby-rspec-support>=${pkgver%.*}.0"
+options="!check" # rspec's tests are written in rspec
+source="$pkgname-$pkgver.tar.gz::https://github.com/rspec/$_gemname/archive/v$pkgver.tar.gz
+ gemspec.patch"
+builddir="$srcdir/$_gemname-$pkgver"
+
+build() {
+ cd "$builddir"
+ gem build $_gemname.gemspec
+}
+
+package() {
+ local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+
+ cd "$builddir"
+ gem install --local \
+ --install-dir "$gemdir" \
+ --ignore-dependencies \
+ --no-document \
+ --verbose \
+ $_gemname
+
+ # Clean-up...
+ rm -r "$gemdir"/cache \
+ "$gemdir"/build_info \
+ "$gemdir"/doc
+}
+
+sha512sums="bdd3222089299e9bfdd6f17a2b8af81d5e695290a3ce976630d586d51ff2df5baf76a3887b8adb31294bd6623ba85f8c2a4a31ac520046515aeeb81fa3a1bd5a ruby-rspec-expectations-3.7.0.tar.gz
+1d477004521852e23d01b197187dbb434a2c7fd179e506c82a12e17f5d52470fe2a113112e7052b9479077eafa6759beb07c03301de1f8ea7f5c4643c92d8346 gemspec.patch"
diff --git a/community/ruby-rspec-expectations/gemspec.patch b/community/ruby-rspec-expectations/gemspec.patch
new file mode 100644
index 0000000000..644aad1ada
--- /dev/null
+++ b/community/ruby-rspec-expectations/gemspec.patch
@@ -0,0 +1,12 @@
+--- a/rspec-expectations.gemspec
++++ b/rspec-expectations.gemspec
+@@ -13,8 +13,7 @@
+ s.summary = "rspec-expectations-#{RSpec::Expectations::Version::STRING}"
+ s.description = "rspec-expectations provides a simple, readable API to express expected outcomes of a code example."
+
+- s.files = `git ls-files -- lib/*`.split("\n")
+- s.files += %w[README.md LICENSE.md Changelog.md .yardopts .document]
++ s.files = Dir["lib/**/*"]
+ s.test_files = []
+ s.rdoc_options = ["--charset=UTF-8"]
+ s.require_path = "lib"
diff --git a/community/ruby-rspec-mocks/APKBUILD b/community/ruby-rspec-mocks/APKBUILD
new file mode 100644
index 0000000000..a96924f9af
--- /dev/null
+++ b/community/ruby-rspec-mocks/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ruby-rspec-mocks
+_gemname=${pkgname#ruby-}
+pkgver=3.7.0
+pkgrel=0
+pkgdesc="RSpec's 'test double' framework, with support for stubbing and mocking"
+url="https://relishapp.com/rspec/rspec-mocks/"
+arch="noarch"
+license="MIT"
+depends="ruby ruby-diff-lcs ruby-rspec-support>=${pkgver%.*}.0"
+options="!check" # rspec's tests are written in rspec
+source="$pkgname-$pkgver.tar.gz::https://github.com/rspec/$_gemname/archive/v$pkgver.tar.gz
+ gemspec.patch"
+builddir="$srcdir/$_gemname-$pkgver"
+
+build() {
+ cd "$builddir"
+ gem build $_gemname.gemspec
+}
+
+package() {
+ local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+
+ cd "$builddir"
+ gem install --local \
+ --install-dir "$gemdir" \
+ --ignore-dependencies \
+ --no-document \
+ --verbose \
+ $_gemname
+
+ # Clean-up...
+ rm -r "$gemdir"/cache \
+ "$gemdir"/build_info \
+ "$gemdir"/doc
+}
+
+sha512sums="8673726571ccf8a901281e44faeb25ffcb59579dc380138f0557cd9310192cd340081e5e8ad65ae281777727b502cca2f6877134b0fb48f2e0ea40b133002aff ruby-rspec-mocks-3.7.0.tar.gz
+6fd7ab08b20a93f806a8d3c42da5da0a99162793079ecb1695341a04dff2a7cefdb12592d1798fb844dfbdf8ead6ad0b8729e461d3cd5af46d853b182d15228d gemspec.patch"
diff --git a/community/ruby-rspec-mocks/gemspec.patch b/community/ruby-rspec-mocks/gemspec.patch
new file mode 100644
index 0000000000..5d4f6e7753
--- /dev/null
+++ b/community/ruby-rspec-mocks/gemspec.patch
@@ -0,0 +1,12 @@
+--- a/rspec-mocks.gemspec
++++ b/rspec-mocks.gemspec
+@@ -13,8 +13,7 @@
+ s.summary = "rspec-mocks-#{RSpec::Mocks::Version::STRING}"
+ s.description = "RSpec's 'test double' framework, with support for stubbing and mocking"
+
+- s.files = `git ls-files -- lib/*`.split("\n")
+- s.files += %w[README.md LICENSE.md Changelog.md .yardopts .document]
++ s.files = Dir["lib/**/*"]
+ s.test_files = []
+ s.rdoc_options = ["--charset=UTF-8"]
+ s.require_path = "lib"
diff --git a/community/ruby-rspec-support/APKBUILD b/community/ruby-rspec-support/APKBUILD
new file mode 100644
index 0000000000..327542cd66
--- /dev/null
+++ b/community/ruby-rspec-support/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ruby-rspec-support
+_gemname=${pkgname#ruby-}
+pkgver=3.7.0
+pkgrel=0
+pkgdesc="Support utilities for RSpec gems"
+url="https://relishapp.com/rspec/rspec-support/"
+arch="noarch"
+license="MIT"
+depends="ruby"
+options="!check" # rspec's tests are written in rspec
+source="$pkgname-$pkgver.tar.gz::https://github.com/rspec/$_gemname/archive/v$pkgver.tar.gz
+ gemspec.patch"
+builddir="$srcdir/$_gemname-$pkgver"
+
+build() {
+ cd "$builddir"
+ gem build $_gemname.gemspec
+}
+
+package() {
+ local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+
+ cd "$builddir"
+ gem install --local \
+ --install-dir "$gemdir" \
+ --ignore-dependencies \
+ --no-document \
+ --verbose \
+ $_gemname
+
+ # Clean-up...
+ rm -r "$gemdir"/cache \
+ "$gemdir"/build_info \
+ "$gemdir"/doc
+}
+
+sha512sums="a4a3fc705d4c31d760777513f86d8b0ca4c9e540b0a6f4b6d1152676f252e1276fedebe7cd259f0dbbb60b447cc179eea194f3a3e5bb023907923cbf16fc8033 ruby-rspec-support-3.7.0.tar.gz
+e9d611ea1789e835f742aa92f1e668840139e2621898edf158dc53e111db4119a324da65d2d28f5c6e737c82f261f4adb3beb8c244ee01d2f618778ed62d3731 gemspec.patch"
diff --git a/community/ruby-rspec-support/gemspec.patch b/community/ruby-rspec-support/gemspec.patch
new file mode 100644
index 0000000000..069c937299
--- /dev/null
+++ b/community/ruby-rspec-support/gemspec.patch
@@ -0,0 +1,12 @@
+--- a/rspec-support.gemspec
++++ b/rspec-support.gemspec
+@@ -13,8 +13,7 @@
+ spec.description = "Support utilities for RSpec gems"
+ spec.license = "MIT"
+
+- spec.files = `git ls-files -- lib/*`.split("\n")
+- spec.files += %w[README.md LICENSE.md Changelog.md]
++ spec.files = Dir["lib/**/*"]
+ spec.test_files = []
+ spec.rdoc_options = ["--charset=UTF-8"]
+ spec.require_paths = ["lib"]
diff --git a/community/ruby-rspec/APKBUILD b/community/ruby-rspec/APKBUILD
new file mode 100644
index 0000000000..ef343fbfe8
--- /dev/null
+++ b/community/ruby-rspec/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ruby-rspec
+_gemname=${pkgname#ruby-}
+pkgver=3.7.0
+pkgrel=0
+pkgdesc="Behaviour Driven Development for Ruby"
+url="http://rspec.info/"
+arch="noarch"
+license="MIT"
+depends="ruby
+ ruby-rspec-core>=${pkgver%.*}.0
+ ruby-rspec-expectations>=${pkgver%.*}.0
+ ruby-rspec-mocks>=${pkgver%.*}.0"
+options="!check" # no tests provided
+source="$pkgname-$pkgver.tar.gz::https://github.com/rspec/$_gemname/archive/v$pkgver.tar.gz
+ gemspec.patch"
+builddir="$srcdir/$_gemname-$pkgver"
+
+build() {
+ cd "$builddir"
+ gem build $_gemname.gemspec
+}
+
+package() {
+ local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+
+ cd "$builddir"
+ gem install --local \
+ --install-dir "$gemdir" \
+ --ignore-dependencies \
+ --no-document \
+ --verbose \
+ $_gemname
+
+ # Clean-up...
+ rm -r "$gemdir"/cache \
+ "$gemdir"/build_info \
+ "$gemdir"/doc
+}
+
+sha512sums="7bfb70f368a718077365fb81849905705d5268bae9463447466c910220d4812752abc057f7da2822eb5593e9d5ac2764ff3e05faafb7feb4d2a140334e23e848 ruby-rspec-3.7.0.tar.gz
+f554eef881574e68532dd6c9edeb6b8ad172ac707f7518134378e1099a40ada959c6c770514aab13a6345343113594208be0e42044803c0c2cde3adde00c5520 gemspec.patch"
diff --git a/community/ruby-rspec/gemspec.patch b/community/ruby-rspec/gemspec.patch
new file mode 100644
index 0000000000..1bd3937c3a
--- /dev/null
+++ b/community/ruby-rspec/gemspec.patch
@@ -0,0 +1,14 @@
+--- a/rspec.gemspec
++++ b/rspec.gemspec
+@@ -14,10 +14,7 @@
+ s.summary = "rspec-#{RSpec::Version::STRING}"
+ s.description = "BDD for Ruby"
+
+- s.files = `git ls-files -- lib/*`.split("\n")
+- s.files += ["LICENSE.md"]
+- s.test_files = `git ls-files -- {spec,features}/*`.split("\n")
+- s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
++ s.files = Dir["lib/**/*"]
+ s.extra_rdoc_files = [ "README.md" ]
+ s.rdoc_options = ["--charset=UTF-8"]
+ s.require_path = "lib"