aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/libwmf/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/community/libwmf/APKBUILD b/community/libwmf/APKBUILD
index 73d0c2b0fe..6802ac1e4e 100644
--- a/community/libwmf/APKBUILD
+++ b/community/libwmf/APKBUILD
@@ -1,11 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libwmf
pkgver=0.2.8.4
-pkgrel=3
+pkgrel=4
pkgdesc="A library for reading vector images in Microsoft's native Windows Metafile Format (WMF)."
url="http://wvware.sourceforge.net/libwmf.html"
arch="all"
license="LGPL"
+depends="ghostscript-fonts"
makedepends="libpng-dev>=1.4.0 freetype-dev jpeg-dev>=8 expat-dev"
install=
subpackages="$pkgname-dev"
@@ -15,9 +16,10 @@ source="http://downloads.sourceforge.net/sourceforge/wvware/$pkgname-$pkgver.tar
builddir="$srcdir"/$pkgname-$pkgver
prepare() {
+ default_prepare
+ update_config_guess
+
cd "$builddir"
- default_prepare || return 1
- update_config_guess || return 1
sed -i -e 's/src include fonts doc/src include fonts/g' Makefile.in
}
@@ -27,12 +29,14 @@ build() {
--with-gsfontdir=/usr/share/fonts/Type1 \
--with-fontdir=/usr/share/fonts/Type1 \
--with-gsfontmap=/usr/share/ghostscript/8.15/lib/Fontmap.GS
- make || return 1
+ make
}
package() {
cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ make -j1 DESTDIR="$pkgdir" install
+ # Remove fonts, these are in ghostscript-fonts
+ rm -rf "$pkgdir/usr/share/fonts"
}
sha512sums="d98df8e76a52245487b13e5ab3d2fbba9d246f97ee04a7344c0e5861bb2d0f990fc6d662dbd849ce621768b06eaebd4270fb34bec4ee004334a98b14ba6044a5 libwmf-0.2.8.4.tar.gz