aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/py-django-compressor/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/py-django-compressor/APKBUILD b/community/py-django-compressor/APKBUILD
new file mode 100644
index 0000000000..abd1127c0a
--- /dev/null
+++ b/community/py-django-compressor/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+pkgname=py-django-compressor
+pkgver=1.5
+pkgrel=0
+pkgdesc="JavaScript and CSS compressor for Django"
+url=https://github.com/django-compressor/django-compressor
+arch=noarch
+license="MIT and ASL 2.0 and BSD"
+depends="py-django py-django-appconf"
+makedepends=py-setuptools
+source="https://files.pythonhosted.org/packages/source/d/django_compressor/django_compressor-$pkgver.tar.gz"
+
+_builddir=$srcdir/django_compressor-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root "$pkgdir"
+}
+
+md5sums="274dd82a45ddd13e111852dd101a5924 django_compressor-1.5.tar.gz"
+sha256sums="0189fd1dbf87d802f4e4e21ebc9220f29bbb7771b252a958ad6119f61453e22e django_compressor-1.5.tar.gz"
+sha512sums="962efe6d39328306005b8d9212cb2d07b50d4bed896d1344cccbb910286f58cd12ae1f264367ba0adb02940acd7b00c2afd5fdeef4210a4d789626183e3d7a5a django_compressor-1.5.tar.gz"