aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/libmpdclient/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/libmpdclient/APKBUILD b/community/libmpdclient/APKBUILD
new file mode 100644
index 0000000000..bb64963b1f
--- /dev/null
+++ b/community/libmpdclient/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libmpdclient
+pkgver=2.13
+pkgrel=1
+pkgdesc="An asynchronous API library for interfacing MPD in the C, C++ & Objective C languages"
+url="https://www.musicpd.org/libs/libmpdclient"
+arch="all"
+license="GPL2"
+depends=""
+makedepends="meson"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://www.musicpd.org/download/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+package() {
+ cd "$builddir"
+ DESTDIR="$pkgdir" ninja -C output install
+
+ mkdir -p "$pkgdir"/usr/share/licenses/$pkgname/
+ mv "$pkgdir"/usr/share/doc/libmpdclient/COPYING \
+ "$pkgdir"/usr/share/licenses/$pkgname/
+}
+
+sha512sums="a2aa4e1e4fcb4ab390a0a38e745e59a9764c40bfcd07d449fdc7fef7b0c5fc0c2e795ef545b6fa6d62c00861d306cab41ea43011510ad1e3a60603873a3c1b28 libmpdclient-2.13.tar.xz"