aboutsummaryrefslogtreecommitdiffstats
path: root/core
diff options
context:
space:
mode:
Diffstat (limited to 'core')
-rw-r--r--core/abuild/APKBUILD9
-rw-r--r--core/alpine-baselayout/APKBUILD17
-rw-r--r--core/alpine-baselayout/mdev-initd.patch13
-rw-r--r--core/alpine-baselayout/mdev-usbdisk.patch36
-rw-r--r--core/apk-tools/APKBUILD4
-rw-r--r--core/autoconf/APKBUILD13
-rw-r--r--core/automake/APKBUILD4
-rw-r--r--core/build-base/APKBUILD5
-rw-r--r--core/e2fsprogs/APKBUILD12
-rw-r--r--core/lvm2/APKBUILD6
-rw-r--r--core/mkinitfs/APKBUILD10
-rw-r--r--core/mkinitfs/init.patch39
-rw-r--r--core/mtools/APKBUILD7
-rw-r--r--core/openrc/APKBUILD17
-rw-r--r--core/openrc/openrc-gendepends-speedup.patch24
-rw-r--r--core/openrc/openrc.post-upgrade9
-rw-r--r--core/syslinux/APKBUILD4
-rw-r--r--core/zlib/APKBUILD5
18 files changed, 159 insertions, 75 deletions
diff --git a/core/abuild/APKBUILD b/core/abuild/APKBUILD
index a21c205148..c68050df9b 100644
--- a/core/abuild/APKBUILD
+++ b/core/abuild/APKBUILD
@@ -1,18 +1,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgdesc="Script to build Alpine Packages"
pkgname=abuild
-pkgver=1.14
-pkgrel=0
+pkgver=1.15.2
+pkgrel=1
url=http://git.alpinelinux.org/cgit/abuild/
source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2
"
-depends="fakeroot file sudo"
+depends="fakeroot file sudo pax-utils"
license=GPL-2
build() {
cd "$srcdir/$pkgname-$pkgver"
+
make install DESTDIR="$pkgdir"
install -m 644 abuild.conf "$pkgdir"/etc/abuild.conf
}
-md5sums="25463a14946eab5b120851e8077679a5 abuild-1.14.tar.bz2"
+md5sums="dd03e8e79b3b4fa9bc17a9acc1b4e520 abuild-1.15.2.tar.bz2"
diff --git a/core/alpine-baselayout/APKBUILD b/core/alpine-baselayout/APKBUILD
index 85ab413224..6f449f190c 100644
--- a/core/alpine-baselayout/APKBUILD
+++ b/core/alpine-baselayout/APKBUILD
@@ -1,17 +1,22 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-baselayout
-pkgver=2.0_alpha11
-pkgrel=1
+pkgver=2.0_alpha12
+pkgrel=2
pkgdesc="Alpine base dir structure and init scripts"
url=http://git.alpinelinux.org/cgit/alpine-baselayout
-depends="uclibc"
-source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2"
+depends=
+source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
+ mdev-usbdisk.patch
+ mdev-initd.patch"
license=GPL-2
build() {
cd "$srcdir"/$pkgname-$pkgver
+ patch -p1 < ../mdev-usbdisk.patch
+ patch -p1 < ../mdev-initd.patch
make
make install PREFIX= DESTDIR="$pkgdir" || return 1
- chmod 700 "$pkgdir"/root
}
-md5sums="5b9d5506690e7cf41e92be5202c40630 alpine-baselayout-2.0_alpha11.tar.bz2"
+md5sums="5549065f87374ea5c4249cba6ba85d16 alpine-baselayout-2.0_alpha12.tar.bz2
+4bf6829d019d2b43dd45208c7390c91c mdev-usbdisk.patch
+6d3c5789e6f02c209a6f7fbf047ea3df mdev-initd.patch"
diff --git a/core/alpine-baselayout/mdev-initd.patch b/core/alpine-baselayout/mdev-initd.patch
new file mode 100644
index 0000000000..2af8497648
--- /dev/null
+++ b/core/alpine-baselayout/mdev-initd.patch
@@ -0,0 +1,13 @@
+diff --git a/init.d/mdev b/init.d/mdev
+index fb9e8d5..42f6a1c 100755
+--- a/init.d/mdev
++++ b/init.d/mdev
+@@ -2,7 +2,7 @@
+
+ depend() {
+ provide dev
+- need sysfs mdev-mount
++ need sysfs
+ before checkfs fsck
+ keyword novserver
+ }
diff --git a/core/alpine-baselayout/mdev-usbdisk.patch b/core/alpine-baselayout/mdev-usbdisk.patch
new file mode 100644
index 0000000000..cfa0331fab
--- /dev/null
+++ b/core/alpine-baselayout/mdev-usbdisk.patch
@@ -0,0 +1,36 @@
+commit 9542c009af40331e8770256148aa13075f4d8294
+Author: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu Jun 4 14:11:43 2009 +0000
+
+ mdev: look for FAT in device to create usbdisk link
+
+ it seems like mkfs.vfat creates MBR signature
+
+diff --git a/mdev.conf b/mdev.conf
+index 3e2339b..6ee65a2 100644
+--- a/mdev.conf
++++ b/mdev.conf
+@@ -27,7 +27,7 @@ ptmx root:tty 0666
+ # ram.*
+ ram([0-9]*) root:disk 0660 >rd/%1
+ loop([0-9]+) root:disk 0660 >loop/
+-sd[a-z]1 root:disk 0660 */lib/mdev/usbdisk_link
++sd[a-z].* root:disk 0660 */lib/mdev/usbdisk_link
+ hd[a-z][0-9]* root:disk 0660 */lib/mdev/ide_links
+ md[0-9] root:disk 0660
+
+diff --git a/usbdisk_link b/usbdisk_link
+index 6acaad3..750242b 100644
+--- a/usbdisk_link
++++ b/usbdisk_link
+@@ -14,8 +14,8 @@ if [ -e /sys/block/$MDEV ]; then
+ # if /sys device path contains '/usb[0-9]' then we assume its usb
+ # also, if its an usb without partitions we require FAT
+ if [ "${SYSDEV##*/usb[0-9]}" != "$SYSDEV" ]; then
+- # do not create link if there is an MBR signature
+- dd if=/dev/$MDEV bs=1 count=2 skip=510 2>/dev/null | hexdump | grep aa55 >/dev/null && exit 0
++ # do not create link if there is not FAT
++ dd if=/dev/$MDEV bs=512 count=1 2>/dev/null | strings | grep FAT >/dev/null || exit 0
+
+ ln -sf $MDEV usbdisk
+ # keep this for compat. people have it in fstab
diff --git a/core/apk-tools/APKBUILD b/core/apk-tools/APKBUILD
index d1c5c0c630..f4ece5d32c 100644
--- a/core/apk-tools/APKBUILD
+++ b/core/apk-tools/APKBUILD
@@ -3,7 +3,7 @@ pkgname=apk-tools
pkgver=2.0_pre12
pkgrel=1
pkgdesc="Alpine Package Keeper - package manager for alpine"
-depends="uclibc"
+depends=
makedepends="zlib-dev"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
fd-leak.patch"
@@ -14,7 +14,7 @@ build() {
cd "$srcdir/$pkgname-$pkgver"
patch -p1 < ../fd-leak.patch || return 1
sed -i -e 's:-Werror::' Make.rules
- make
+ make || return 1
make DESTDIR="$pkgdir" install
cd "$pkgdir/sbin"
ln -s apk apk_add
diff --git a/core/autoconf/APKBUILD b/core/autoconf/APKBUILD
index 67bf8646d6..8de79f6ef3 100644
--- a/core/autoconf/APKBUILD
+++ b/core/autoconf/APKBUILD
@@ -1,9 +1,8 @@
-
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=autoconf
pkgver=2.63
pkgrel=1
pkgdesc="A GNU tool for automatically configuring source code"
-arch=i486
license="GPL2 GPL3"
url="http://www.gnu.org/software/autoconf"
depends="m4 perl"
@@ -11,13 +10,13 @@ source="ftp://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"
subpackages="$pkgname-doc"
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr
+ cd "$srcdir"/$pkgname-$pkgver
+ M4=/usr/bin/m4 ./configure --prefix=/usr
make || return 1
- make DESTDIR=${pkgdir} install || return 1
- rm -f ${pkgdir}/usr/share/info/dir
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/share/info/dir
# conflict with bintuils
- rm -f ${pkgdir}/usr/share/info/standards.info
+ rm -f "$pkgdir"/usr/share/info/standards.info
}
md5sums='43d76649fb86cd21d64f68c48d5abdcf autoconf-2.63.tar.gz'
diff --git a/core/automake/APKBUILD b/core/automake/APKBUILD
index 05fe9dccce..356f68e3f5 100644
--- a/core/automake/APKBUILD
+++ b/core/automake/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=automake
-pkgver=1.10.2
+pkgver=1.11
pkgrel=0
pkgdesc="A GNU tool for automatically creating Makefiles"
arch=i486
@@ -18,4 +18,4 @@ build() {
make DESTDIR=$pkgdir install
}
-md5sums="ede3e08c696861a01f4d2c6a2e822053 automake-1.10.2.tar.gz"
+md5sums="fab0bd2c3990a6679adaf9eeac0c6d2a automake-1.11.tar.gz"
diff --git a/core/build-base/APKBUILD b/core/build-base/APKBUILD
index 1d42d78180..32c4e93b62 100644
--- a/core/build-base/APKBUILD
+++ b/core/build-base/APKBUILD
@@ -1,8 +1,9 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=build-base
-pkgver=0.1
+pkgver=0.2
url=http://dev.alpinelinux.org/cgit
pkgdesc="Meta package for build base"
-depends="binutils gcc make patch uclibc-dev"
+depends="binutils gcc make patch uclibc-dev g++"
license=none
build() {
diff --git a/core/e2fsprogs/APKBUILD b/core/e2fsprogs/APKBUILD
index 8252eead06..466f1a0abd 100644
--- a/core/e2fsprogs/APKBUILD
+++ b/core/e2fsprogs/APKBUILD
@@ -1,11 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=e2fsprogs
-pkgver=1.41.5
+pkgver=1.41.6
pkgrel=0
pkgdesc="Standard Ext2/3/4 filesystem utilities"
url="http://e2fsprogs.sourceforge.net"
license="GPL LGPL MIT"
-depends="uclibc libuuid libcom_err libblkid"
+depends=
subpackages="$pkgname-dev $pkgname-doc libuuid libcom_err libblkid"
source="http://downloads.sourceforge.net/sourceforge/e2fsprogs/e2fsprogs-$pkgver.tar.gz"
@@ -23,21 +23,21 @@ build () {
}
libuuid() {
- depends="uclibc"
+ depends=
mkdir -p "$subpkgdir"/lib
mv "$pkgdir"/lib/libuuid* "$subpkgdir"/lib/
}
libcom_err() {
- depends="uclibc"
+ depends=
mkdir -p "$subpkgdir"/lib
mv "$pkgdir"/lib/libcom_err* "$subpkgdir"/lib/
}
libblkid() {
- depends="uclibc libuuid"
+ depends=
mkdir -p "$subpkgdir"/lib
mv "$pkgdir"/lib/libblkid* "$subpkgdir"/lib/
}
-md5sums="e218df6c84fc17c1126d31de9472a76c e2fsprogs-1.41.5.tar.gz"
+md5sums="732c559db400c8fc994f4f38568c9f1f e2fsprogs-1.41.6.tar.gz"
diff --git a/core/lvm2/APKBUILD b/core/lvm2/APKBUILD
index 07df9f6005..59384f4879 100644
--- a/core/lvm2/APKBUILD
+++ b/core/lvm2/APKBUILD
@@ -1,11 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lvm2
-pkgver=2.02.45
+pkgver=2.02.47
pkgrel=0
pkgdesc="Logical Volume Manager 2 utilities"
url="http://sourceware.org/lvm2/"
license="GPL"
-depends="uclibc readline"
+depends=
makedepends="readline-dev"
source="ftp://sources.redhat.com/pub/$pkgname/LVM2.$pkgver.tgz
lvm.initd
@@ -31,5 +31,5 @@ build () {
install -d "$pkgdir"/etc/lvm/archive "$pkgdir"/etc/lvm/backup
install -Dm755 "$srcdir"/lvm.initd "$pkgdir"/etc/init.d/lvm
}
-md5sums="440daa01b8f2ec4fe97b1cc621108220 LVM2.2.02.45.tgz
+md5sums="669d57ff97d171fd4e077c61da1f9a34 LVM2.2.02.47.tgz
e60d88f78eedb9c1252deb5b9b9b978b lvm.initd"
diff --git a/core/mkinitfs/APKBUILD b/core/mkinitfs/APKBUILD
index f4a37223fe..bc79fc1411 100644
--- a/core/mkinitfs/APKBUILD
+++ b/core/mkinitfs/APKBUILD
@@ -1,16 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mkinitfs
pkgver=1.5
-pkgrel=0
+pkgrel=1
pkgdesc="Tool to generate initramfs images for Alpine"
url=http://git.alpinelinux.org/cgit/mkinitfs
depends="busybox"
-source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2"
+source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
+ init.patch
+ "
license="GPL-2"
build() {
cd "$srcdir"/$pkgname-$pkgver
+ patch -p1 < ../init.patch
make
make install DESTDIR="$pkgdir" || return 1
}
-md5sums="0a7eefb454fc96763983048ee60a1bcd mkinitfs-1.5.tar.bz2"
+md5sums="0a7eefb454fc96763983048ee60a1bcd mkinitfs-1.5.tar.bz2
+deb3fa8e83c877e72e6b3b420cef3864 init.patch"
diff --git a/core/mkinitfs/init.patch b/core/mkinitfs/init.patch
new file mode 100644
index 0000000000..6f2c367eff
--- /dev/null
+++ b/core/mkinitfs/init.patch
@@ -0,0 +1,39 @@
+commit db606b4b4861076524232f52002411dc900a03ad
+Author: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu Jun 4 14:56:28 2009 +0000
+
+ init: unpack uclibc when dealing with encrypted apkovls
+
+ openssl needs libdl which is not there by default.
+
+diff --git a/initramfs-init.in b/initramfs-init.in
+index f8827a0..ae82e8a 100755
+--- a/initramfs-init.in
++++ b/initramfs-init.in
+@@ -66,6 +66,14 @@ retry_mount() {
+ return 1
+ }
+
++unpack_apk() {
++ local i
++ for i in $ALPINE_MNT/*/*/$1-[0-9]*.apk $ALPINE_MNT/*/$1-[0-9]*.apk; do
++ [ -f "$i" ] && tar --numeric-owner -C / -zxf $i && return 0
++ done
++ return 1
++}
++
+ unpack_apkovl() {
+ local ovl="$1"
+ local dest="$2"
+@@ -76,9 +84,8 @@ unpack_apkovl() {
+ return $?
+ fi
+
+- for i in $ALPINE_MNT/*/*/openssl-[0-9]*.apk $ALPINE_MNT/*/openssl-[0-9]*.apk; do
+- [ -f "$i" ] && tar --numeric-owner -C / -zxf $i && break
+- done
++ unpack_apk uclibc
++ unpack_apk openssl
+
+ if ! openssl list-cipher-commands | grep "^$suffix$" > /dev/null; then
+ errstr="Cipher $suffix is not supported"
diff --git a/core/mtools/APKBUILD b/core/mtools/APKBUILD
index 0b84bdd616..b556426163 100644
--- a/core/mtools/APKBUILD
+++ b/core/mtools/APKBUILD
@@ -1,11 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mtools
pkgver=4.0.10
-pkgrel=0
+pkgrel=2
pkgdesc="A collection of utilities to access MS-DOS disks from Unix without mounting them"
url="http://www.gnu.org/software/mtools/"
license="GPL"
-depends="uclibc"
+depends=
makedepends="texinfo"
source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.bz2"
subpackages="$pkgname-doc"
@@ -15,7 +15,8 @@ build () {
./configure --prefix=/usr \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --sysconfdir=/etc
+ --sysconfdir=/etc \
+ --without-x
make || return 1
make -j1 install DESTDIR="$pkgdir"
}
diff --git a/core/openrc/APKBUILD b/core/openrc/APKBUILD
index ecf30e0768..f7a56e285d 100644
--- a/core/openrc/APKBUILD
+++ b/core/openrc/APKBUILD
@@ -1,16 +1,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=openrc
-pkgver=0.4.3
-pkgrel=4
+pkgver=0.5.0
+pkgrel=1
pkgdesc="OpenRC manages the services, startup and shutdown of a host"
url="http://roy.marples.name/openrc"
license='BSD-2'
-depends="uclibc"
+depends=""
subpackages="$pkgname-doc $pkgname-dev"
-install="$pkgname.post-install"
+install="$pkgname.post-install $pkgname.post-upgrade"
source="http://roy.marples.name/downloads/$pkgname/$pkgname-$pkgver.tar.bz2
openrc-0.4.3-mkmntdirs.patch
- openrc-gendepends-speedup.patch
hostname.initd
keymaps.initd
modules.initd
@@ -31,7 +30,7 @@ build() {
# we cannot have anything turned on by default
rm -f "$pkgdir"/etc/runlevels/*/*
- rm -f "$pkgdir"/lib/rc/net/* "$pkgdir"/etc/init.d/net.lo
+ #rm -f "$pkgdir"/lib/rc/net/* "$pkgdir"/etc/init.d/net.lo
# we override some of the scripts
for i in ../*.initd; do
@@ -41,11 +40,11 @@ build() {
}
-md5sums="57ca95533e629f06a0775e176e19bdb5 openrc-0.4.3.tar.bz2
+md5sums="9ec7f8425e12abbbd0f7a962aae3fa3c openrc-0.5.0.tar.bz2
8c2c1c2ee0509b63966b7187a2079f4b openrc-0.4.3-mkmntdirs.patch
-dcdcb34591e3d9eaaaf82db736cc5135 openrc-gendepends-speedup.patch
c32e15b0858eef708497e7ee6355a055 hostname.initd
33ca3e558c42cdd17adccbc7807298f7 keymaps.initd
5608e6e3d836ad01b9714e5b41d223cb modules.initd
747168eee535e845179eaef5a3fcb334 networking.initd
-6e834194b246563fc5acd77e91e038c4 openrc.post-install"
+6e834194b246563fc5acd77e91e038c4 openrc.post-install
+393ff61bc0bf2c07f9af81795554c584 openrc.post-upgrade"
diff --git a/core/openrc/openrc-gendepends-speedup.patch b/core/openrc/openrc-gendepends-speedup.patch
deleted file mode 100644
index 528b571695..0000000000
--- a/core/openrc/openrc-gendepends-speedup.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Index: sh/gendepends.sh.in
-===================================================================
---- a/sh/gendepends.sh.in (revision 1511)
-+++ b/sh/gendepends.sh.in (working copy)
-@@ -81,6 +81,7 @@
- [ -e @SYSCONFDIR@/rc.conf ] && . @SYSCONFDIR@/rc.conf
-
- if . "${_dir}/${RC_SVCNAME}"; then
-+ _shell_var_RC_SVCNAME=$(shell_var "${RC_SVCNAME}")
- echo "${RC_SVCNAME}" >&3
- depend
-
-@@ -91,9 +92,9 @@
- IFS=:
- set -- ${_deptype}
- unset IFS
-- eval _depends=\$rc_$(shell_var "${RC_SVCNAME}")_$1
-+ eval _depends=\$rc_${_shell_var_RC_SVCNAME}_$1
- [ -z "${_depends}" ] && eval _depends=\$rc_$1
-- [ -z "${_depends}" ] && eval _depends=\$RC_$(shell_var "${RC_SVCNAME}")_$2
-+ [ -z "${_depends}" ] && eval _depends=\$RC_${_shell_var_RC_SVCNAME}_$2
- [ -z "${_depends}" ] && eval _depends=\$RC_$2
-
- $1 ${_depends}
diff --git a/core/openrc/openrc.post-upgrade b/core/openrc/openrc.post-upgrade
new file mode 100644
index 0000000000..b09f2f240c
--- /dev/null
+++ b/core/openrc/openrc.post-upgrade
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+# in 0.5.x the state dir moved from /lib/rc/init.d to /libexec/rc/init.d
+
+[ -d /lib/rc/init.d ] || exit 0
+
+mv /lib/rc/init.d/* /libexec/rc/init.d/
+rmdir /lib/rc/init.d
+exit 0
diff --git a/core/syslinux/APKBUILD b/core/syslinux/APKBUILD
index c05168cf10..e7036c0f87 100644
--- a/core/syslinux/APKBUILD
+++ b/core/syslinux/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=syslinux
-pkgver=3.80
+pkgver=3.81
pkgrel=0
pkgdesc="a boot loader for the Linux operating system which operates off an MS-DOS/Windows FAT filesystem."
url="http://syslinux.org"
@@ -21,5 +21,5 @@ build ()
make INSTALLROOT="$pkgdir" MANDIR=/usr/share/man local-install
}
-md5sums="b909ea282a408dfb5dd95c5e0fa3d5b5 syslinux-3.80.tar.bz2
+md5sums="9be7f19e65aa8ffad325ccff1b6175a4 syslinux-3.81.tar.bz2
c08398d165d29e48711e55058e2897de syslinux-3.72-nopie.patch"
diff --git a/core/zlib/APKBUILD b/core/zlib/APKBUILD
index 72738d4032..5a171860e2 100644
--- a/core/zlib/APKBUILD
+++ b/core/zlib/APKBUILD
@@ -1,10 +1,11 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=zlib
pkgver=1.2.3.3
-pkgrel=3
+pkgrel=4
pkgdesc="A compression/decompression Library"
license=custom:zlib
url="http://www.gzip.org/zlib"
-depends='uclibc'
+depends=
source="ftp://ftp.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"
subpackages="$pkgname-dev $pkgname-doc"