aboutsummaryrefslogtreecommitdiffstats
path: root/extra/fetchmail
diff options
context:
space:
mode:
Diffstat (limited to 'extra/fetchmail')
-rw-r--r--extra/fetchmail/APKBUILD44
-rwxr-xr-xextra/fetchmail/fetchmail.initd33
-rw-r--r--extra/fetchmail/fetchmail.post-install3
-rw-r--r--extra/fetchmail/fetchmail.pre-install4
4 files changed, 0 insertions, 84 deletions
diff --git a/extra/fetchmail/APKBUILD b/extra/fetchmail/APKBUILD
deleted file mode 100644
index 092556638a..0000000000
--- a/extra/fetchmail/APKBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-# Contributor: Michael Mason <ms13sp@gmail.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=fetchmail
-pkgver=6.3.9
-pkgrel=3
-pkgdesc="A remote-mail retrieval and forwarding utility"
-url="http://fetchmail.berlios.de/"
-license="GPL"
-depends=
-makedepends="openssl-dev python"
-install="fetchmail.pre-install fetchmail.post-install"
-subpackages="$pkgname-doc fetchmailconf"
-source="http://download.berlios.de/fetchmail/$pkgname-$pkgver.tar.bz2
- $install
- fetchmail.initd"
-build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --with-ssl \
- --disable-nls
- make || return 1
- make DESTDIR="$pkgdir" install
- install -Dm755 "$srcdir"/fetchmail.initd "$pkgdir"/etc/init.d/fetchmail
- install -d "$pkgdir"/var/lib/fetchmail "$pkgdir"/var/run/fetchmail
-}
-
-fetchmailconf() {
- depends="python"
- pkgdesc="A GUI for generating fetchmail configuration files"
- install=
- mkdir -p "$subpkgdir"/usr/bin
- cd "$pkgdir"
- mv usr/bin/fetchmailconf "$subpkgdir"/usr/bin/
- mv usr/lib "$subpkgdir"/usr/
-}
-
-md5sums="72c20ad2b9629f1a109668b05a84d823 fetchmail-6.3.9.tar.bz2
-5a2fc8e8b3115fe2b9bf23503fb8f0a4 fetchmail.pre-install
-4b451d102e92926b6b6c1774f4260310 fetchmail.post-install
-22e9ac1d8385db05da15e01fd5c831e4 fetchmail.initd"
diff --git a/extra/fetchmail/fetchmail.initd b/extra/fetchmail/fetchmail.initd
deleted file mode 100755
index a1ed1ec837..0000000000
--- a/extra/fetchmail/fetchmail.initd
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/sbin/runscript
-
-pidfile=/var/run/fetchmail/fetchmail.pid
-
-depend() {
- need net
- use mta
-}
-
-checkconfig() {
- if [ ! -f /etc/fetchmailrc ]; then
- eerror "Configuration file /etc/fetchmailrc not found"
- return 1
- fi
-}
-
-start() {
- checkconfig || return 1
-
- ebegin "Starting fetchmail"
- start-stop-daemon --start --quiet \
- --chuid fetchmail --exec /usr/bin/fetchmail \
- -- -d ${polling_period:-300} -f /etc/fetchmailrc \
- --pidfile ${pidfile} -i /var/lib/fetchmail/.fetchids
- eend ${?}
-}
-
-stop() {
- ebegin "Stopping fetchmail"
- start-stop-daemon --stop --quiet --pidfile ${pidfile}
- eend ${?}
-}
-
diff --git a/extra/fetchmail/fetchmail.post-install b/extra/fetchmail/fetchmail.post-install
deleted file mode 100644
index b16bfcc3e4..0000000000
--- a/extra/fetchmail/fetchmail.post-install
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-chown fetchmail:fetchmail /var/*/fetchmail
diff --git a/extra/fetchmail/fetchmail.pre-install b/extra/fetchmail/fetchmail.pre-install
deleted file mode 100644
index 4a1b630e00..0000000000
--- a/extra/fetchmail/fetchmail.pre-install
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-
-adduser -H -h /var/lib/fetchmail -s /bin/false -D fetchmail 2>/dev/null
-exit 0