aboutsummaryrefslogtreecommitdiffstats
path: root/extra/sntpc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/sntpc/APKBUILD')
-rw-r--r--extra/sntpc/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/extra/sntpc/APKBUILD b/extra/sntpc/APKBUILD
new file mode 100644
index 0000000000..b1315e06b6
--- /dev/null
+++ b/extra/sntpc/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=sntpc
+pkgver=0.9
+pkgrel=0
+pkgdesc="Simple NTP client"
+url="http://dev.alpinelinux.org/cgit/cgit.cgi/sntpc"
+license="GPL-2"
+depends="uclibc"
+source="http://dev.alpinelinux.org/cgit/cgit.cgi/sntpc/snapshot/sntpc-0.9.tar.bz2
+ sntpc.initd
+ sntpc.confd
+ "
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ make || return 1
+ install -m755 -D sntpc "$pkgdir"/usr/sbin/sntpc
+ install -m755 -D "$srcdir"/sntpc.initd "$pkgdir"/etc/init.d/sntpc
+ install -m644 -D "$srcdir"/sntpc.confd "$pkgdir"/etc/conf.d/sntpc
+}
+
+md5sums="f42fb17ef688e0cea7e0267b1ec837ee sntpc-0.9.tar.bz2
+c5018237685af2cddb0b4ede1751bee1 sntpc.initd
+4ea1ceee01f94080be86188bde8f9adc sntpc.confd"