aboutsummaryrefslogtreecommitdiffstats
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/popt/APKBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/extra/popt/APKBUILD b/extra/popt/APKBUILD
new file mode 100644
index 0000000000..4826bd2d28
--- /dev/null
+++ b/extra/popt/APKBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=popt
+pkgver=1.14
+pkgrel=0
+pkgdesc="Parse Options - Command line parser"
+url="http://rpm5.org/"
+license="as-is"
+depends="uclibc"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://rpm5.org/files/popt/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --without-included-gettext \
+ --disable-nls || return 1
+ make || return 1
+ make install DESTDIR="$pkgdir"
+}
+md5sums="4f90a07316eb825604dd10ae4f9f3f04 popt-1.14.tar.gz"