aboutsummaryrefslogtreecommitdiffstats
path: root/main/abuild/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/abuild/APKBUILD')
-rw-r--r--main/abuild/APKBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 989c7bebea..f1d6b6cd8f 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgdesc="Script to build Alpine Packages"
pkgname=abuild
-pkgver=2.3
+pkgver=2.5
pkgrel=0
url=http://git.alpinelinux.org/cgit/abuild/
source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2
@@ -10,6 +10,18 @@ depends="fakeroot file sudo pax-utils openssl apk-tools"
makedepends="openssl-dev pkgconfig"
license=GPL-2
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
build() {
cd "$srcdir/$pkgname-$pkgver"
make
@@ -21,4 +33,4 @@ package() {
install -m 644 abuild.conf "$pkgdir"/etc/abuild.conf
}
-md5sums="7c738e0018202160366b8329ec693502 abuild-2.3.tar.bz2"
+md5sums="2173f4775cb2672661cfc3de55c8450e abuild-2.5.tar.bz2"