aboutsummaryrefslogtreecommitdiffstats
path: root/main/abuild/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/abuild/APKBUILD')
-rw-r--r--main/abuild/APKBUILD22
1 files changed, 17 insertions, 5 deletions
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index a2da7713d2..db4c2cc67f 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,7 +2,7 @@
pkgname=abuild
pkgver=2.23.0
_ver=${pkgver%_git*}
-pkgrel=2
+pkgrel=3
pkgdesc="Script to build Alpine Packages"
url="http://git.alpinelinux.org/cgit/abuild/"
arch="all"
@@ -16,11 +16,12 @@ makedepends_build="pkgconfig"
makedepends_host="openssl-dev"
makedepends="$makedepends_host $makedepends_build"
install="$pkgname.pre-install $pkgname.pre-upgrade"
-subpackages="apkbuild-cpan:cpan"
+subpackages="apkbuild-cpan:cpan apkbuild-gem-resolver:gems"
options="suid"
pkggroups="abuild"
source="http://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.xz
0001-abuild-fix-circular-dependency-for-symlink-deps.patch
+ 0002-apkbuild-gem-resolver-fix-syntax.patch
"
_builddir="$srcdir/$pkgname-$_ver"
@@ -57,9 +58,20 @@ cpan() {
mv "$pkgdir"/usr/bin/apkbuild-cpan "$subpkgdir"/usr/bin/
}
+gems() {
+ pkgdesc="APKBUILD dependency resolver for RubyGems"
+ depends="ruby ruby-augeas"
+ arch="noarch"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/apkbuild-gem-resolver "$subpkgdir"/usr/bin/
+}
+
md5sums="864090a6016b3424d7b6bb31e84db3f0 abuild-2.23.0.tar.xz
-c8ef8f4155d445842cc20379dbe01ded 0001-abuild-fix-circular-dependency-for-symlink-deps.patch"
+c8ef8f4155d445842cc20379dbe01ded 0001-abuild-fix-circular-dependency-for-symlink-deps.patch
+8d96bd94711cb172586a483a089bb5c8 0002-apkbuild-gem-resolver-fix-syntax.patch"
sha256sums="4cae7d7035955d23d1f29d4d0cd00ce225b300e6e809ff240101feea97aa7262 abuild-2.23.0.tar.xz
-2550d9d0dfeeb214aa0154b281a624f977d3b83ba678dc0f727f0c508996f26e 0001-abuild-fix-circular-dependency-for-symlink-deps.patch"
+2550d9d0dfeeb214aa0154b281a624f977d3b83ba678dc0f727f0c508996f26e 0001-abuild-fix-circular-dependency-for-symlink-deps.patch
+239c9b119ba91c254b86fcb700b48dd3f8aae7bc5e902ce04bc839d95478f6b3 0002-apkbuild-gem-resolver-fix-syntax.patch"
sha512sums="50fc7649444079e5ba5552c2f4c57dedbdcd7b10727ed7b7bec8b4c85b37bbca1d76ab61bf3ab160520634e1742c3cd91fb294371bf653330ee0047337b6dfa9 abuild-2.23.0.tar.xz
-4c3d1d778b60de9f9e789501e52ab0f17ef5f2ea5cb05e33cc95d59b98130907bce5ed4c4808244b22f14c17b91682447599aded1579c904cee8cd269bda7c85 0001-abuild-fix-circular-dependency-for-symlink-deps.patch"
+4c3d1d778b60de9f9e789501e52ab0f17ef5f2ea5cb05e33cc95d59b98130907bce5ed4c4808244b22f14c17b91682447599aded1579c904cee8cd269bda7c85 0001-abuild-fix-circular-dependency-for-symlink-deps.patch
+ecd774c509bf45fef15d967a185d5ab7cd4e5e2736d8979b17a8f822622db799eb2a149bedb020b7e9ce0451579a6c7e36f94eaa971b0570ecd6d7adb1a7e00a 0002-apkbuild-gem-resolver-fix-syntax.patch"