aboutsummaryrefslogtreecommitdiffstats
path: root/main/abuild/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/abuild/APKBUILD')
-rw-r--r--main/abuild/APKBUILD18
1 files changed, 16 insertions, 2 deletions
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 989c7bebea..4ad26188c4 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,14 +2,27 @@
pkgdesc="Script to build Alpine Packages"
pkgname=abuild
pkgver=2.3
-pkgrel=0
+pkgrel=1
url=http://git.alpinelinux.org/cgit/abuild/
source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2
+ abuild-conflict-message.patch
"
depends="fakeroot file sudo pax-utils openssl apk-tools"
makedepends="openssl-dev pkgconfig"
license=GPL-2
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
build() {
cd "$srcdir/$pkgname-$pkgver"
make
@@ -21,4 +34,5 @@ package() {
install -m 644 abuild.conf "$pkgdir"/etc/abuild.conf
}
-md5sums="7c738e0018202160366b8329ec693502 abuild-2.3.tar.bz2"
+md5sums="7c738e0018202160366b8329ec693502 abuild-2.3.tar.bz2
+45ee7aa6e00732a8c36d7740fb8d2aeb abuild-conflict-message.patch"