aboutsummaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/0001-Revert-abuild-minor-cleanup.patch31
-rw-r--r--main/abuild/APKBUILD16
2 files changed, 14 insertions, 33 deletions
diff --git a/main/abuild/0001-Revert-abuild-minor-cleanup.patch b/main/abuild/0001-Revert-abuild-minor-cleanup.patch
deleted file mode 100644
index 25569b5b6d..0000000000
--- a/main/abuild/0001-Revert-abuild-minor-cleanup.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 19b2598f8a52ba8af07eb4904788d0843130b094 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Tue, 27 Oct 2009 15:24:18 +0000
-Subject: [PATCH] Revert "abuild: minor cleanup"
-
-This commit seems to kill the entire repository
-
-This reverts commit 46aed95754ebeb17a3a367b3b41d0b6424fd18d9.
----
- buildrepo.in | 4 ++--
- 1 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/buildrepo.in b/buildrepo.in
-index d719c34..c211789 100755
---- a/buildrepo.in
-+++ b/buildrepo.in
-@@ -22,9 +22,9 @@ usage() {
-
-
- listpackages() {
-+ cd "$aportsdir/$1"
- for i in */APKBUILD; do
-- cd "$aportsdir"/$1/${i%/*}
-- abuild listpkg
-+ APKBUILD=$i abuild listpkg
- done
- }
-
---
-1.6.5
-
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 989c7bebea..f1d6b6cd8f 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgdesc="Script to build Alpine Packages"
pkgname=abuild
-pkgver=2.3
+pkgver=2.5
pkgrel=0
url=http://git.alpinelinux.org/cgit/abuild/
source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2
@@ -10,6 +10,18 @@ depends="fakeroot file sudo pax-utils openssl apk-tools"
makedepends="openssl-dev pkgconfig"
license=GPL-2
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
build() {
cd "$srcdir/$pkgname-$pkgver"
make
@@ -21,4 +33,4 @@ package() {
install -m 644 abuild.conf "$pkgdir"/etc/abuild.conf
}
-md5sums="7c738e0018202160366b8329ec693502 abuild-2.3.tar.bz2"
+md5sums="2173f4775cb2672661cfc3de55c8450e abuild-2.5.tar.bz2"