aboutsummaryrefslogtreecommitdiffstats
path: root/main/aiccu/fix_linking.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/aiccu/fix_linking.patch')
-rw-r--r--main/aiccu/fix_linking.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/main/aiccu/fix_linking.patch b/main/aiccu/fix_linking.patch
new file mode 100644
index 0000000000..100220149b
--- /dev/null
+++ b/main/aiccu/fix_linking.patch
@@ -0,0 +1,29 @@
+--- a/unix-console/Makefile
++++ b/unix-console/Makefile
+@@ -42,7 +42,7 @@
+ # Currently defaultly builds only on Linux, but other platforms might easily also support it
+ ifeq ($(shell uname | grep -c "Linux"),1)
+ CFLAGS += -D AICCU_GNUTLS
+-LDFLAGS += -lgnutls
++LIBS += -lgnutls
+ endif
+
+ # Linux
+@@ -50,7 +50,7 @@
+ CFLAGS += -D_LINUX -D HAS_IFHEAD -D AICCU_TYPE="\"linux\""
+ SRCS += ../common/aiccu_linux.c
+ OBJS += ../common/aiccu_linux.o
+-LDFLAGS += -lpthread -lresolv
++LIBS += -lpthread -lresolv
+ endif
+
+ # FreeBSD
+@@ -144,7 +144,7 @@
+ all: aiccu
+
+ aiccu: $(OBJS) ${SRCS} ${INCS}
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+ ifeq ($(shell echo $(CFLAGS) | grep -c "DEBUG"),0)
+ ifeq ($(shell echo "$(RPM_OPT_FLAGS)" | wc -c),1)
+ strip $@