aboutsummaryrefslogtreecommitdiffstats
path: root/main/alpine-baselayout
diff options
context:
space:
mode:
Diffstat (limited to 'main/alpine-baselayout')
-rw-r--r--main/alpine-baselayout/0001-profile-set-system-environment-charset-to-UTF-8.patch21
-rw-r--r--main/alpine-baselayout/APKBUILD11
2 files changed, 30 insertions, 2 deletions
diff --git a/main/alpine-baselayout/0001-profile-set-system-environment-charset-to-UTF-8.patch b/main/alpine-baselayout/0001-profile-set-system-environment-charset-to-UTF-8.patch
new file mode 100644
index 0000000000..ee7f1c542f
--- /dev/null
+++ b/main/alpine-baselayout/0001-profile-set-system-environment-charset-to-UTF-8.patch
@@ -0,0 +1,21 @@
+From 43c026c2ef8e63726aff987b7c7b65039aa8d455 Mon Sep 17 00:00:00 2001
+From: William Pitcock <nenolod@dereferenced.org>
+Date: Mon, 14 Mar 2011 11:32:45 -0500
+Subject: [PATCH] profile: set system environment charset to UTF-8
+
+---
+ profile | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/profile b/profile
+index a292008..3480248 100644
+--- a/profile
++++ b/profile
+@@ -1,3 +1,4 @@
++export CHARSET=UTF-8
+ export PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
+ export PAGER=less
+ export PS1='\h:\w\$ '
+--
+1.7.4.1
+
diff --git a/main/alpine-baselayout/APKBUILD b/main/alpine-baselayout/APKBUILD
index 382873326e..67b8a9adfe 100644
--- a/main/alpine-baselayout/APKBUILD
+++ b/main/alpine-baselayout/APKBUILD
@@ -1,15 +1,21 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-baselayout
pkgver=2.0_rc1
-pkgrel=2
+pkgrel=3
pkgdesc="Alpine base dir structure and init scripts"
url=http://git.alpinelinux.org/cgit/alpine-baselayout
depends=
source="http://git.alpinelinux.org/cgit/$pkgname.git/snapshot/$pkgname-$pkgver.tar.bz2
+ 0001-profile-set-system-environment-charset-to-UTF-8.patch
"
arch="all"
license=GPL-2
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -p1 < "$srcdir"/0001-profile-set-system-environment-charset-to-UTF-8.patch
+}
+
build() {
cd "$srcdir"/$pkgname-$pkgver
rm -f src/mkmntdirs
@@ -20,4 +26,5 @@ package() {
cd "$srcdir"/$pkgname-$pkgver
make install PREFIX= DESTDIR="$pkgdir" || return 1
}
-md5sums="76d61057c9e21d8e3ef85933a20b814d alpine-baselayout-2.0_rc1.tar.bz2"
+md5sums="76d61057c9e21d8e3ef85933a20b814d alpine-baselayout-2.0_rc1.tar.bz2
+b4eb3fdb4ca0aa136c87ca0c32e25742 0001-profile-set-system-environment-charset-to-UTF-8.patch"