aboutsummaryrefslogtreecommitdiffstats
path: root/main/apache-mod-auth-ntlm-winbind/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/apache-mod-auth-ntlm-winbind/APKBUILD')
-rw-r--r--main/apache-mod-auth-ntlm-winbind/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/main/apache-mod-auth-ntlm-winbind/APKBUILD b/main/apache-mod-auth-ntlm-winbind/APKBUILD
new file mode 100644
index 0000000000..1165ddd81e
--- /dev/null
+++ b/main/apache-mod-auth-ntlm-winbind/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Jeff Bilyk <jbilyk@gmail.com>
+# Maintainer: Natanael Copa <natanael.copa@gmail.com>
+pkgname=apache-mod-auth-ntlm-winbind
+pkgver=0.1
+pkgrel=1
+pkgdesc="Authentication module for Apache using NTLM protocol with winbind helper"
+url="http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/"
+license="Apache2"
+depends="apache2 samba winbind"
+makedepends="autoconf apache2-dev apr-util-dev apr-dev"
+source="http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/mod_auth_ntlm_winbind.c
+http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/configure.in
+http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/Makefile.in
+mod-auth-ntlm-winbind.conf"
+
+build() {
+ cd "$srcdir"
+ autoconf
+ ./configure
+ make DESTDIR="$pkgdir" || return 1
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir"/etc/apache2/conf.d
+ mkdir -p "$pkgdir"/usr/lib/apache2
+ install mod-auth-ntlm-winbind.conf "$pkgdir"/etc/apache2/conf.d/mod-auth-ntlm-winbind.conf
+ install "$srcdir"/.libs/mod_auth_ntlm_winbind.so "$pkgdir"/usr/lib/apache2/mod_auth_ntlm_winbind.so
+}
+
+md5sums="01d32e311e6a404bcf4179c863081818 mod_auth_ntlm_winbind.c
+e1490dae6e468d4bc56154b16e5d8c24 configure.in
+410de8b0ac7ffe5c44a71d094190187d Makefile.in
+331b392c7aaa13b3a9ea8780ce2db3d4 mod-auth-ntlm-winbind.conf"