aboutsummaryrefslogtreecommitdiffstats
path: root/main/apk-tools/fix-crossbuild.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/apk-tools/fix-crossbuild.patch')
-rw-r--r--main/apk-tools/fix-crossbuild.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/main/apk-tools/fix-crossbuild.patch b/main/apk-tools/fix-crossbuild.patch
new file mode 100644
index 0000000000..7f5dcacc4b
--- /dev/null
+++ b/main/apk-tools/fix-crossbuild.patch
@@ -0,0 +1,14 @@
+diff --git a/src/Makefile b/src/Makefile
+index 250d2f0..0e0525a 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -66,7 +66,7 @@ LDFLAGS_apk += -L$(obj)
+ LDFLAGS_apk-test += -L$(obj)
+
+ CFLAGS_ALL += $(shell $(PKG_CONFIG) --cflags $(PKGDEPS))
+-LIBS := /usr/lib/libfetch.a \
++LIBS := $(shell $(CC) -print-file-name=libfetch.a) \
+ -Wl,--as-needed \
+ $(shell $(PKG_CONFIG) --libs $(PKGDEPS)) \
+ -Wl,--no-as-needed
+