aboutsummaryrefslogtreecommitdiffstats
path: root/main/augeas/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/augeas/APKBUILD')
-rw-r--r--main/augeas/APKBUILD122
1 files changed, 69 insertions, 53 deletions
diff --git a/main/augeas/APKBUILD b/main/augeas/APKBUILD
index db9e53a3ab..0f050a77ab 100644
--- a/main/augeas/APKBUILD
+++ b/main/augeas/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=augeas
pkgver=1.4.0
-pkgrel=2
+pkgrel=3
pkgdesc="A configuration editing tool"
url="http://augeas.net"
arch="all"
@@ -20,13 +20,17 @@ source="http://download.augeas.net/augeas-$pkgver.tar.gz
0006-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
0007-Shellvars-allow-quotes-in-loop-conditions.patch
0008-Shellvars-case-support-quotes-and-spaces-in-pattern-.patch
- 0009-Shellvars-pattern-nodes-in-case-entries.patch
- 0010-Shellvars-use-sto_to_semicol-in-condition-lens.patch
- 0011-Shellvars-allow-and-constructs-after-condition.patch
- 0012-Shellvars-Allow-almost-any-command.patch
- 0013-Shellvars-test-case-for-wrapping-command-arguments.patch
- 0014-Shellvars-allow-command-specific-environment-variabl.patch
- 0015-Shellvars-allow-and-constructs-after-command.patch"
+ 0009-Shellvars-add-eval-builtin-support.patch
+ 0010-Shellvars-add-alias-builtin-support.patch
+ 0011-Shellvars-pattern-nodes-in-case-entries.patch
+ 0012-Shellvars-use-sto_to_semicol-in-condition-lens.patch
+ 0013-Shellvars-allow-and-constructs-after-condition.patch
+ 0014-Shellvars-Allow-almost-any-command.patch
+ 0015-Shellvars-support-pipes-in-commands.patch
+ 0016-Shellvars-allow-in-commands.patch
+ 0017-Shellvars-test-case-for-wrapping-command-arguments.patch
+ 0018-Shellvars-allow-command-specific-environment-variabl.patch
+ 0019-Shellvars-allow-wrapping-command-sequences.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -76,50 +80,62 @@ libs() {
}
md5sums="a2536a9c3d744dc09d234228fe4b0c93 augeas-1.4.0.tar.gz
-dd18a5a32b334ef3b7e6e82058c61eaa 0001-Shellvars-accept-and-builtins.patch
-e6a07b02ee5181b5957d6f568c70739f 0002-Shellvars-Add-test-for.patch
-33696bba63ac77dd3b9135565ececd0e 0003-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
-9957857fbf7b6e9d9e072854e983cc3e 0004-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch
-99fb6ebd2d87e6d5d51bd8247b1bfee8 0005-Shellvars-guard-against-comments.patch
-fa2f0d09ab6256b349af9155bbd4fa23 0006-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
-6d3804e6243360eeebaf0e3187d42c9c 0007-Shellvars-allow-quotes-in-loop-conditions.patch
-f1e6bc097099d5cbb7f57514bd20c1cc 0008-Shellvars-case-support-quotes-and-spaces-in-pattern-.patch
-2c2d132a5d91540ea8c4bee299fced52 0009-Shellvars-pattern-nodes-in-case-entries.patch
-d4db1ad5da2e2f6a469c2fe56717948d 0010-Shellvars-use-sto_to_semicol-in-condition-lens.patch
-5d60247adedb864c8daef3f72e3b02cc 0011-Shellvars-allow-and-constructs-after-condition.patch
-5456ee24abf568f93feadd8993cefb70 0012-Shellvars-Allow-almost-any-command.patch
-577da7030c48a4dfd793d81a834070b7 0013-Shellvars-test-case-for-wrapping-command-arguments.patch
-b7f6583e3fe1859060cf212038c633d4 0014-Shellvars-allow-command-specific-environment-variabl.patch
-345e0227b918c6ba5406e0d577aba9b0 0015-Shellvars-allow-and-constructs-after-command.patch"
+3392ae3abc40efe5d7c8ce4ce5738df8 0001-Shellvars-accept-and-builtins.patch
+aa2f18bd6b439db9345d7492d260d5a7 0002-Shellvars-Add-test-for.patch
+7ed3fd8d6541716cbb63c11db48de9e0 0003-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
+1420d337f79a9960ed8c6e0d68587f48 0004-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch
+1a233f9d67f0e0c3063e253e3fd3f62b 0005-Shellvars-guard-against-comments.patch
+0ddc164b5e0558b9a8c1e163c5806109 0006-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
+afb986370fca48ca5d5c16c7b7ef6a3c 0007-Shellvars-allow-quotes-in-loop-conditions.patch
+4fd047af91ebf6400fe34b7f2bae7667 0008-Shellvars-case-support-quotes-and-spaces-in-pattern-.patch
+94c30b3ef837bbc16e4e8daf498ee0c6 0009-Shellvars-add-eval-builtin-support.patch
+3e99adf29c5e4d228b5f7e1993e35ff4 0010-Shellvars-add-alias-builtin-support.patch
+9d6302c8a13dc8d348768b2b00310197 0011-Shellvars-pattern-nodes-in-case-entries.patch
+ba07705f460888555f7a7b7ff28d2136 0012-Shellvars-use-sto_to_semicol-in-condition-lens.patch
+a1321510dec7d5ea3f76598b1e673a10 0013-Shellvars-allow-and-constructs-after-condition.patch
+6481d28202a6ed3774f5275c9c23eb28 0014-Shellvars-Allow-almost-any-command.patch
+6370c721ce09c29f2707f37e1cbe1ac5 0015-Shellvars-support-pipes-in-commands.patch
+3ff071044714c89268935589a43d8315 0016-Shellvars-allow-in-commands.patch
+685947f3c076d51fe268585442cee0d3 0017-Shellvars-test-case-for-wrapping-command-arguments.patch
+c27de94c7097126f0ff0d3c72380563a 0018-Shellvars-allow-command-specific-environment-variabl.patch
+a7709c66872d398a1a2688d0fa87e7ef 0019-Shellvars-allow-wrapping-command-sequences.patch"
sha256sums="659fae7ac229029e60a869a3b88c616cfd51cf2fba286cdfe3af3a052cb35b30 augeas-1.4.0.tar.gz
-4e2b4b6aa5efa3af3cc936ddea2877d28501e617967d8fac028fa7859315952b 0001-Shellvars-accept-and-builtins.patch
-50009cc329c6cfeb7f6f3823fd29e2d7a7215bd0b479c7525d22d5cff0f11131 0002-Shellvars-Add-test-for.patch
-d38a0b9608fd8c00cc432ceb244908e413e5c660e8efba8594fc8ad1f59f1209 0003-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
-6518600c844a088c961d2bf03df15099dc5f507b0e442aa7581e1f05c281f10d 0004-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch
-286b9b6bcfa52a1772b114088d75842c543ef548729b903ee359182fa3bb1e0f 0005-Shellvars-guard-against-comments.patch
-b15ad47b8c6e8c02081a2342a965353f4182bd840f3ef7bc18db73e58159c655 0006-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
-11b3f3a0ba74e04e5ac6f340cbb4b4fbcee5bd142534d408d80501c80ca32240 0007-Shellvars-allow-quotes-in-loop-conditions.patch
-55a5c2ab166cbe88287e872c52d3d5e57a73bb587e04b3d2fe8ce6460a132817 0008-Shellvars-case-support-quotes-and-spaces-in-pattern-.patch
-c9bf0528f74a4866661a16f41c1d5e81eb803e593b812b66effa27c04791cd28 0009-Shellvars-pattern-nodes-in-case-entries.patch
-6392c4219f178a241ae4dbf268dbbee7562a0301f1cce7eb43dd82cad6a7cbfa 0010-Shellvars-use-sto_to_semicol-in-condition-lens.patch
-105d148f50e534cc1786b0379d9c69536e922519d7536a297c08bc73526f641d 0011-Shellvars-allow-and-constructs-after-condition.patch
-e4a7a876969166477b5f1517b4c920ff996ced8bc5a41115709e511c7c1a352c 0012-Shellvars-Allow-almost-any-command.patch
-80469ddc2bbbd3b0468d2e7cb703794021b1aeff9a2efd62236048702fcd0b28 0013-Shellvars-test-case-for-wrapping-command-arguments.patch
-df7c1ee1cd823dce1cb6707a362f453bbda0e6d334c1f50e3b0780fe79513947 0014-Shellvars-allow-command-specific-environment-variabl.patch
-a5c93542a462c1ede1f2bc6b92da9506f18622208541a2b353d77a1fc89f593f 0015-Shellvars-allow-and-constructs-after-command.patch"
+646bfcdd6b30f253d50354ba96070018fb3a9f4f123d7a0cfe25b01ec729b176 0001-Shellvars-accept-and-builtins.patch
+8c59fe6a3d3bf1a52a5d110adb1547634c550ce2d318728755fb5ba33ef8c091 0002-Shellvars-Add-test-for.patch
+c6c774342a77f6766e4ceceafe18aeccd05f695da6cfc8b5438e4939d8b8047a 0003-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
+b84c69a6bc2b9de448c2f7b09b68dbac52b9b55cf81b7fd25d210bee1ad37ae3 0004-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch
+f2d514899a46902534a9c7a87f1074fda2b07c45deaeb0bac270decc7c7364ed 0005-Shellvars-guard-against-comments.patch
+e735f982619ef9a623badd68e316e820d5e98f53dc3fb031fbef1918487a7073 0006-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
+b41b2fe13eb9155da6ef2e310961009f6bf978e02a628315b5c0347cc19b54f6 0007-Shellvars-allow-quotes-in-loop-conditions.patch
+63da3848ae0202c258e9ea4a5f8392f2b1fd83a1104e08da120ab0f9e50213d6 0008-Shellvars-case-support-quotes-and-spaces-in-pattern-.patch
+f54a4f8c1b64cf405261c9959b40ab598084ab85dc05e5ab18103f17786d120d 0009-Shellvars-add-eval-builtin-support.patch
+fa64fe69036cacb2d4e94a1ac978e4feb2eea44ed520760814486d1890c06bca 0010-Shellvars-add-alias-builtin-support.patch
+063734ec0dc6eefc8435550372e3fed30695c35e68ae9e7406b32e2b4077a0fb 0011-Shellvars-pattern-nodes-in-case-entries.patch
+6df998175ce3063f0ff027ccb931132a8ff3baca25dba2d518dd93a762727375 0012-Shellvars-use-sto_to_semicol-in-condition-lens.patch
+a53617eb365e0721f9a2d56863039354b9a90255f94923280c43642b47eed34a 0013-Shellvars-allow-and-constructs-after-condition.patch
+d3e954b69e29a80f1a08968dafd462fa413bbef1cc3755d9676ba7e95cd343aa 0014-Shellvars-Allow-almost-any-command.patch
+714b8a1291eb0619230bb3563a78391abb66d1cbe6918ef23f373388e6374d1c 0015-Shellvars-support-pipes-in-commands.patch
+266543e2988dd630d858a45885160b938c55839119472dff4afe66f656978863 0016-Shellvars-allow-in-commands.patch
+a23f777e4b525e7de038de2234dccc732fb6704eeb5a01d1b7d2c5ec979c50bd 0017-Shellvars-test-case-for-wrapping-command-arguments.patch
+e0ab2fdbcb48e0109e59d57505206f63684143847309166f82c1dd5b7385eba2 0018-Shellvars-allow-command-specific-environment-variabl.patch
+a56ed7f49b4e562a6374783f984273aa505ccf4a7ca05bcc721904f684ead2bd 0019-Shellvars-allow-wrapping-command-sequences.patch"
sha512sums="182457698e51be89feadb16879bae2f2413a5761127efb63a9b7ef30806f4059bca614e8c9627b0c7a010b9ec9c03c85161e655bdb2902f7cf43e89b66e312db augeas-1.4.0.tar.gz
-05680719679fed94a6b5032227b99d70706e704cfccfb1abffa80cabc7676d9578882558be146ca2fd182655dbaad76f64e392dc2eed0c22bc7340900258728b 0001-Shellvars-accept-and-builtins.patch
-c3619e40b260e4bbb8ad12d545887b1e9f59d4e14fc909cfa63a4e61db8cfbeed34fade8c48f0a83bc8341b2f9a080953d4e46510d92fb33b72c7cc5e5a5fa5f 0002-Shellvars-Add-test-for.patch
-e3602e45391149fc9dfd16d9bb9f24da200639d303275c0d5ff4a48bfc4d098d030eb8c695dab1ef467df27fb990567c951c21a0da6833d101edd9139a342000 0003-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
-1200f683d0c26d8ef043bca958ce9b7d4e69f7a2321b569c6b436696a3fcf7f2325e2126e630e7699d25157bc95fe84db6e0dedf82f2bda08f6e1e8fd59d091e 0004-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch
-2be7ae4d668fed6f1ca33cd8aab772bb3aac897a2e455129dcd7e3d992aa405649a1f12a3ca0490e84d7c74ec2856fd3797e0ffa2381edf460ad0f01cb8bcd85 0005-Shellvars-guard-against-comments.patch
-11304c8a1560bfaa532efc4d80fd6ef807089c299c3caf54d9156a107e7a520fc4a88d421166e5f4f270ca175cc8ab9c70b0ddad9c6afa8b28939d7e147930be 0006-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
-9afe8fab05a89c5444ea19845aaeda996aecfe4937293b37c74c4ed58a11f480b16de8d196461e9b6d3a695f5748dd49b8d31668a734ddb03092cd66b26b685e 0007-Shellvars-allow-quotes-in-loop-conditions.patch
-f01d11da984e4d8a3b736b70cbd4a06f0ae516bffe076de7c95557d685c939627ce8e801f08caad383b419b8494b0fa472b6adb36ae9ed96c6787f22f5726393 0008-Shellvars-case-support-quotes-and-spaces-in-pattern-.patch
-787c8599bcbafabe2df45a70dfe8f85e1a1c91c78bd08b3c29e969c17f923ef988b435a071f8ce44fcd42769d16a5a49e51fc6aef06df82f40cbdf8b522577e8 0009-Shellvars-pattern-nodes-in-case-entries.patch
-5b6e3167891809c91413d05159b51e1092f96dc3b25c4ab09c462ace21a840600f055b28ee6c17fd449f51788730540463815b934e9e7e0a0e2ccb4127868de5 0010-Shellvars-use-sto_to_semicol-in-condition-lens.patch
-ce8078be725705068d12f0a7885543af2d5ba4915439d8a8c7caa25723faba3961d3cc3dd4f104adbac2ba15b79aa57bcf1e33e61e6f39e51ab9666c1196dbf7 0011-Shellvars-allow-and-constructs-after-condition.patch
-534e72da2348d45ed737a2fe7d38c32facb15ecc47be29825ad30fbeac9e44387b463a708323b6a2d002c3ab5a589f70c7328b4e8e8a1d8e3e1bd54e2d11a820 0012-Shellvars-Allow-almost-any-command.patch
-9c30da11cf0e278d0a68f6daad7d2ae546a91c45fdec637178ab78a2d61e6987e93d1ba7b2566c1974572458822d16befd69b11d0518191019e2ebdf60780013 0013-Shellvars-test-case-for-wrapping-command-arguments.patch
-f668ec144e12ace83340a546331f12de21994c125f34dc3a62bbdc1aee502d28581e756ed04660b170a301925bfad756500ac6cb8d354fb678333909bdc1887a 0014-Shellvars-allow-command-specific-environment-variabl.patch
-1793d37d31e8a9a98353f29f6150b2f0fd7e8bdf682511cda7f4dfc477b0f44713438fb35e40327099857c51288f54c18904264b9dc56b0bbe9912cc34acc487 0015-Shellvars-allow-and-constructs-after-command.patch"
+b178c3b36a87d6eb07fed9016385fd8f179564984fb30f6fed7ba7a55ad50fbd100b27f704aa2fb7b95bd4f6d2f66509c8cb7fe57e45ba0a825a2b00992b4a6b 0001-Shellvars-accept-and-builtins.patch
+0ef979edb7e4a7d7a889f8820c63a969bae7a589a2a5bea579ff7f6ed9804e91f542eada786c8c665f8f5a72b343e600dc79e63103d381e7a8e85126c564b871 0002-Shellvars-Add-test-for.patch
+6fd8ccc3a3673f35864ad2187cd80524d02901ff76d8bdfc4e3dfa2fc9d1a56877c0e774945642a42c5fd1b9b756242e1261d1421521dde4f92ee26d1d00c6e9 0003-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
+65eb4159e67ccfd2dc4afd9ed213061d4edfb286e7325aaf6f898c72b552cb6793c315c03ced32e5ffcba21ce2e40b810c04bdbce9f2fc21ecd184e3885a2e6f 0004-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch
+ae56a3d5eb9ba39b503abbbaf0d4d704afa22014b0f95c0fa1c2410706e975fd2a03c7790314a09667c9fbdba979bc47e0dbf1f8b62afb35666d0ce743dd73c7 0005-Shellvars-guard-against-comments.patch
+c2b635fc45aaf6a585ecdd34408fa231428d812f9d79b2d5e3fe6366fa6a9d4a774731245c6f426f547c767594f4b825e393a669b79b2dffea44a3db6dbfc380 0006-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
+150b79f481ead8e1c38ecc42af747dfa3906b283fc481f0e81ec08b2569aac2872800128ed1fbed3f9d1d98b7406620298c1f975f0cf29cac545020259f75f0a 0007-Shellvars-allow-quotes-in-loop-conditions.patch
+1c8aceb221767c7f3de26d405764a1122058993ca6e6119508037720ef74a66a9c3637bb1b9e665cada26c782b59083f3f80219f06b0cc38177694b7798e7599 0008-Shellvars-case-support-quotes-and-spaces-in-pattern-.patch
+06b7bd2c5d326dd816b49932af8d5a1ca0d1361188a958ec874b2130f195768a4fad43acc01c2768cfb803fef2199df12e2bc03c34f3263e4678416e41b234ab 0009-Shellvars-add-eval-builtin-support.patch
+3bd5aeae956be4902046e51e4bf5200812c6c09b32e550cc186ed5fdeca4be13ffc515849383fb4d16d074459fce0b7a6accecd6bf86624d9b9f3d982b357197 0010-Shellvars-add-alias-builtin-support.patch
+c3f8e2a42979125bea55b7759eccfd2173f57c9fe91fafe2cac6c6309b15fd6eaebc842550577f0b75665381b39ed10e644b995759ee4f9d8d261a48c1dc7b91 0011-Shellvars-pattern-nodes-in-case-entries.patch
+52655bd119b9813e6b90c27975e30190ee8c1273ff929ae392e522ddc382830dd1e230f10bedaeb535fdf0d89aaafa2cb7d8fbbf8c31923105a19b76e1e8a095 0012-Shellvars-use-sto_to_semicol-in-condition-lens.patch
+842d227eabe4ba9571f8d58ec5f936b7ffe6861bada9501f43458627dfe450691eb9589f1d483b83065ba20c5c5e1c571b9081f67f148c4a65474433f32439f8 0013-Shellvars-allow-and-constructs-after-condition.patch
+ba80bbd54e08d0e2ba836334f1b2fddd5b375d4a5cdf2579dbc116297066187220c20d372fcfb4abe3c469c7720a20d877f226fb9215f079ce068c33c53526e5 0014-Shellvars-Allow-almost-any-command.patch
+48aea6e755769969544c6627a0b1993db065dd98e3de07f9d30c8d6caec7aec9fff057c62403bab46dc0551f207879096e58fa4de68683d46685bcb4d96f25a7 0015-Shellvars-support-pipes-in-commands.patch
+43d93a08719f616cb7b4656f9990384be29ca043a2b04cb7e8e6350d0a586402fe7a13d032b32c8e4ca7f04cd48ff15a95b58275ed276fad57e44bd5817dca8f 0016-Shellvars-allow-in-commands.patch
+e46caf1b759e9a402cb27aa4bfa134896fd6816ba2614fa49f407ad8e9fe81b05e4e4fd1e128c8215cf0133aa3dbab000a7c5492c109e85dc23d76b686aa6413 0017-Shellvars-test-case-for-wrapping-command-arguments.patch
+f852015ed1a4bbbca7241f291c6fa6f4bd6fb69ac1c3d62113c2f5bff7e07c4fbc82469ea69f8ac3d5cb905dd95e34e9ed05682d6568173eab1fe933737f5de5 0018-Shellvars-allow-command-specific-environment-variabl.patch
+0b1ef0b3bbd22da7c35140ddb8b6855c33d93fb0f0004804a5acf2be55828434d5a719f6b94e256d4e6585bf0e4857b57f659a8ae557d5ad819fbc5d8b0e4264 0019-Shellvars-allow-wrapping-command-sequences.patch"