aboutsummaryrefslogtreecommitdiffstats
path: root/main/avahi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/avahi/APKBUILD')
-rw-r--r--main/avahi/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/avahi/APKBUILD b/main/avahi/APKBUILD
index 05b9a54098..bad49f3f6d 100644
--- a/main/avahi/APKBUILD
+++ b/main/avahi/APKBUILD
@@ -33,7 +33,10 @@ build ()
{
cd "$srcdir/$pkgname-$pkgver"
# we dont build autoipd since dhcpcd does same job
- ./configure --prefix=/usr \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--disable-autoipd \
@@ -47,7 +50,8 @@ build ()
--enable-compat-libdns_sd \
--enable-compat-howl \
--with-distro="gentoo" \
- --with-systemdsystemunitdir=/lib/systemd/system
+ --with-systemdsystemunitdir=/lib/systemd/system \
+ || return 1
make
}