aboutsummaryrefslogtreecommitdiffstats
path: root/main/awall/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/awall/APKBUILD')
-rw-r--r--main/awall/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/main/awall/APKBUILD b/main/awall/APKBUILD
index 539a3551bc..f14a43533e 100644
--- a/main/awall/APKBUILD
+++ b/main/awall/APKBUILD
@@ -2,17 +2,20 @@
# Maintainer: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
pkgname=awall
pkgver=1.4.2
-pkgrel=0
+pkgrel=1
pkgdesc="Alpine Wall"
url="http://git.alpinelinux.org/cgit/awall/"
+_luaver=5.2
arch="noarch"
license="GPL2"
replaces="awall-nat"
-depends="bind-tools ip6tables ipset iptables lua lua-alt-getopt lua-cjson
- lua-pc lua-posix lua-stringy xtables-addons"
+depends="bind-tools ip6tables ipset iptables lua$_luaver lua$_luaver-alt-getopt lua$_luaver-cjson
+ lua$_luaver-pc lua$_luaver-posix lua$_luaver-stringy xtables-addons"
subpackages=$pkgname-masquerade
triggers="$pkgname.trigger=/usr/share/awall"
-source="http://dev.alpinelinux.org/archive/awall/awall-$pkgver.tar.xz"
+source="http://dev.alpinelinux.org/archive/awall/awall-$pkgver.tar.xz
+ yaml-toml-support.patch
+ "
_builddir=$srcdir/awall-$pkgver
prepare() {
@@ -25,22 +28,24 @@ prepare() {
}
build() {
+ sed -i -e "1,1s:lua:lua$_luaver:" awall-cli
return 0
}
package() {
cd "$_builddir"
- make "ROOT_DIR=$pkgdir" install
+ make "ROOT_DIR=$pkgdir" LUA_VERSION=$_luaver install
}
masquerade() {
depends=awall
cd "$_builddir"
- for file in lua/5.1/awall/modules/masquerade.lua awall/mandatory/masquerade.json; do
+ for file in lua/$_luaver/awall/modules/masquerade.lua awall/mandatory/masquerade.json; do
local path=usr/share/$file
install -d "$subpkgdir/$(dirname $path)"
mv "$pkgdir/$path" "$subpkgdir/$path"
done
}
-sha512sums="1c58c6c9ecc9394bb5f19338224edb5eeff82d5139a78ede85ab04fbd35be21e3fd7f7c8fd5938460a754113372cb3f39c02d9e551dda84450c4515a856a21cd awall-1.4.2.tar.xz"
+sha512sums="1c58c6c9ecc9394bb5f19338224edb5eeff82d5139a78ede85ab04fbd35be21e3fd7f7c8fd5938460a754113372cb3f39c02d9e551dda84450c4515a856a21cd awall-1.4.2.tar.xz
+a76d0b2decd6277b3b723d874de7aaa1a9e9b444e025307fbfa8ef4b97cb98a53c44dfcb5f15bcd649e0a849e07ecd85f9d3ee10e9d259ecdc68324fc53cc20a yaml-toml-support.patch"