aboutsummaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/0001-beep-the-d-option-takes-milliseconds-not-microsecond.patch25
-rw-r--r--main/busybox/APKBUILD4
2 files changed, 28 insertions, 1 deletions
diff --git a/main/busybox/0001-beep-the-d-option-takes-milliseconds-not-microsecond.patch b/main/busybox/0001-beep-the-d-option-takes-milliseconds-not-microsecond.patch
new file mode 100644
index 0000000000..15d8e10927
--- /dev/null
+++ b/main/busybox/0001-beep-the-d-option-takes-milliseconds-not-microsecond.patch
@@ -0,0 +1,25 @@
+From 4d277601bdd3717ff304b2eef9823cc4c17134e2 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu, 11 Mar 2010 17:06:59 +0000
+Subject: [PATCH] beep: the -d option takes milliseconds not microseconds
+
+---
+ miscutils/beep.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/miscutils/beep.c b/miscutils/beep.c
+index c17cbfd..10768e7 100644
+--- a/miscutils/beep.c
++++ b/miscutils/beep.c
+@@ -83,7 +83,7 @@ int beep_main(int argc, char **argv)
+ usleep(1000 * length);
+ ioctl(speaker, KIOCSOUND, (void*)0);
+ if (--rep)
+- usleep(delay);
++ usleep(1000 * delay);
+ }
+ }
+
+--
+1.7.0.2
+
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index 82d7e8b9ed..b54140d47e 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.16.0
-pkgrel=4
+pkgrel=5
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
license="GPL-2"
@@ -20,6 +20,7 @@ source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
busybox-1.16.0-tftp.patch
busybox-1.16.0-usage.patch
busybox-1.16.0-wget.patch
+ 0001-beep-the-d-option-takes-milliseconds-not-microsecond.patch
busyboxconfig"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -72,4 +73,5 @@ f4758daa8023f000228e9509cceb02d1 busybox-1.16.0-md5_sha_compat.patch
e24dc9e56b5de4fff706cfbe5c75d9b2 busybox-1.16.0-tftp.patch
289c8ee19cc43fe175bbd7933c6b5cdf busybox-1.16.0-usage.patch
928ca5a26599cd1dbb80e08132140832 busybox-1.16.0-wget.patch
+00b2aca448952eeb3b579792070712fd 0001-beep-the-d-option-takes-milliseconds-not-microsecond.patch
9743e7ecd48f37b0d420f64bef7fb2a8 busyboxconfig"