aboutsummaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/0001-acpid-do-not-install-handlers-for-fatal-signals.patch42
-rw-r--r--main/busybox/0001-acpid-fix-for-clean-exit-on-SIGTERM.patch30
-rw-r--r--main/busybox/0001-grep-support-for-x-match-whole-line.patch68
-rw-r--r--main/busybox/APKBUILD21
4 files changed, 117 insertions, 44 deletions
diff --git a/main/busybox/0001-acpid-do-not-install-handlers-for-fatal-signals.patch b/main/busybox/0001-acpid-do-not-install-handlers-for-fatal-signals.patch
new file mode 100644
index 0000000000..b62ab4aade
--- /dev/null
+++ b/main/busybox/0001-acpid-do-not-install-handlers-for-fatal-signals.patch
@@ -0,0 +1,42 @@
+From bbf1e3c144c1ee93409a0e0546cb56b34eccfcfd Mon Sep 17 00:00:00 2001
+From: Denys Vlasenko <vda.linux@googlemail.com>
+Date: Sun, 5 Feb 2012 15:08:08 +0100
+Subject: [PATCH 1/4] acpid: do not install handlers for fatal signals
+
+For acpid, it's ok to die at once.
+
+Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
+---
+ util-linux/acpid.c | 8 ++++++--
+ 1 files changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/util-linux/acpid.c b/util-linux/acpid.c
+index 361a2b2..1b22f3a 100644
+--- a/util-linux/acpid.c
++++ b/util-linux/acpid.c
+@@ -268,8 +268,12 @@ int acpid_main(int argc UNUSED_PARAM, char **argv)
+
+ xchdir(opt_dir);
+
++ /* We spawn children but don't wait for them. Prevent zombies: */
+ bb_signals((1 << SIGCHLD), SIG_IGN);
+- bb_signals(BB_FATAL_SIGS, record_signo);
++ // If you enable this, (1) explain why, (2)
++ // make sure while(poll) loop below is still interruptible
++ // by SIGTERM et al:
++ //bb_signals(BB_FATAL_SIGS, record_signo);
+
+ pfd = NULL;
+ nfd = 0;
+@@ -337,7 +341,7 @@ int acpid_main(int argc UNUSED_PARAM, char **argv)
+ }
+ if (!event)
+ continue;
+- // spawn event handler
++ /* spawn event handler */
+ process_event(event);
+ }
+ }
+--
+1.7.9.1
+
diff --git a/main/busybox/0001-acpid-fix-for-clean-exit-on-SIGTERM.patch b/main/busybox/0001-acpid-fix-for-clean-exit-on-SIGTERM.patch
deleted file mode 100644
index 4218971889..0000000000
--- a/main/busybox/0001-acpid-fix-for-clean-exit-on-SIGTERM.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 4d5e59384109ab83309f07b67a1e2eef1f392daf Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 3 Feb 2012 14:32:51 +0100
-Subject: [PATCH] acpid: fix for clean exit on SIGTERM
-
-f4b2f335506e570a06d5eab09068da3f61 introduced safe_poll() and no
-longer exits on SIGTERM. We solve this by explicit checking for
-bb_got_signal.
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- util-linux/acpid.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/util-linux/acpid.c b/util-linux/acpid.c
-index 361a2b2..63c7a6d 100644
---- a/util-linux/acpid.c
-+++ b/util-linux/acpid.c
-@@ -293,7 +293,7 @@ int acpid_main(int argc UNUSED_PARAM, char **argv)
-
- write_pidfile(opt_pidfile);
-
-- while (safe_poll(pfd, nfd, -1) > 0) {
-+ while (safe_poll(pfd, nfd, -1) > 0 && !bb_got_signal) {
- int i;
- for (i = 0; i < nfd; i++) {
- const char *event;
---
-1.7.9
-
diff --git a/main/busybox/0001-grep-support-for-x-match-whole-line.patch b/main/busybox/0001-grep-support-for-x-match-whole-line.patch
new file mode 100644
index 0000000000..db8c4f2d9b
--- /dev/null
+++ b/main/busybox/0001-grep-support-for-x-match-whole-line.patch
@@ -0,0 +1,68 @@
+From 7a526de36684e0c794c125d552931f59a91e445c Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu, 23 Feb 2012 14:08:45 +0000
+Subject: [PATCH] grep: support for -x, match whole line
+
+Specified in POSIX.
+http://pubs.opengroup.org/onlinepubs/009604499/utilities/grep.html
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ findutils/grep.c | 12 +++++++++---
+ 1 file changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/findutils/grep.c b/findutils/grep.c
+index 5f42242..6125aca 100644
+--- a/findutils/grep.c
++++ b/findutils/grep.c
+@@ -85,6 +85,7 @@
+ //usage: "\n -r Recurse"
+ //usage: "\n -i Ignore case"
+ //usage: "\n -w Match whole words only"
++//usage: "\n -x Match whole lines only"
+ //usage: "\n -F PATTERN is a literal (not regexp)"
+ //usage: IF_FEATURE_GREP_EGREP_ALIAS(
+ //usage: "\n -E PATTERN is an extended regexp"
+@@ -113,7 +114,7 @@
+ //usage:#define fgrep_full_usage ""
+
+ #define OPTSTR_GREP \
+- "lnqvscFiHhe:f:Lorm:w" \
++ "lnqvscFiHhe:f:Lorm:wx" \
+ IF_FEATURE_GREP_CONTEXT("A:B:C:") \
+ IF_FEATURE_GREP_EGREP_ALIAS("E") \
+ IF_EXTRA_COMPAT("z") \
+@@ -138,6 +139,7 @@ enum {
+ OPTBIT_r, /* recurse dirs */
+ OPTBIT_m, /* -m MAX_MATCHES */
+ OPTBIT_w, /* -w whole word match */
++ OPTBIT_x, /* -x whole line match */
+ IF_FEATURE_GREP_CONTEXT( OPTBIT_A ,) /* -A NUM: after-match context */
+ IF_FEATURE_GREP_CONTEXT( OPTBIT_B ,) /* -B NUM: before-match context */
+ IF_FEATURE_GREP_CONTEXT( OPTBIT_C ,) /* -C NUM: -A and -B combined */
+@@ -160,6 +162,7 @@ enum {
+ OPT_r = 1 << OPTBIT_r,
+ OPT_m = 1 << OPTBIT_m,
+ OPT_w = 1 << OPTBIT_w,
++ OPT_x = 1 << OPTBIT_x,
+ OPT_A = IF_FEATURE_GREP_CONTEXT( (1 << OPTBIT_A)) + 0,
+ OPT_B = IF_FEATURE_GREP_CONTEXT( (1 << OPTBIT_B)) + 0,
+ OPT_C = IF_FEATURE_GREP_CONTEXT( (1 << OPTBIT_C)) + 0,
+@@ -370,9 +373,12 @@ static int grep_file(FILE *file)
+ &gl->matched_range) >= 0
+ #endif
+ ) {
+- if (!(option_mask32 & OPT_w))
++ if (option_mask32 & OPT_x) {
++ found = (gl->matched_range.rm_so == 0
++ && line[gl->matched_range.rm_eo] == 0);
++ } else if (!(option_mask32 & OPT_w)) {
+ found = 1;
+- else {
++ } else {
+ char c = ' ';
+ if (gl->matched_range.rm_so)
+ c = line[gl->matched_range.rm_so - 1];
+--
+1.7.9.2
+
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index e520d049f5..460c753bbd 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
-pkgver=1.19.3
-pkgrel=7
+pkgver=1.19.4
+pkgrel=1
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
arch="all"
@@ -20,12 +20,8 @@ source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
0001-loginutils-use-sha512.patch
acpid.patch
busybox-mkdir-permissions-64bit.patch
- 0001-acpid-fix-for-clean-exit-on-SIGTERM.patch
-
- http://busybox.net/downloads/fixes-1.19.3/busybox-1.19.3-getty.patch
- http://busybox.net/downloads/fixes-1.19.3/busybox-1.19.3-modinfo.patch
- http://busybox.net/downloads/fixes-1.19.3/busybox-1.19.3-wget.patch
- http://busybox.net/downloads/fixes-1.19.3/busybox-1.19.3-mdev.patch
+ 0001-acpid-do-not-install-handlers-for-fatal-signals.patch
+ 0001-grep-support-for-x-match-whole-line.patch
busyboxconfig"
@@ -87,7 +83,7 @@ static() {
"$subpkgdir"/bin/busybox.static
}
-md5sums="c3938e1ac59602387009bbf1dd1af7f6 busybox-1.19.3.tar.bz2
+md5sums="9c0cae5a0379228e7b55e5b29528df8e busybox-1.19.4.tar.bz2
b7b06c7d5cff6935e4ff68a245cc64b5 bbsuid.c
d64b58a30892c558bdbab7f0d0997577 nologin.c
4c0f3b486eaa0674961b7ddcd0c60a9b busybox-1.11.1-bb.patch
@@ -96,9 +92,6 @@ b5375210f13fd6e1ca61a565e8fabd35 busybox-uname-is-not-gnu.patch
784383013b8f015fb0d214618c46b4b8 0001-loginutils-use-sha512.patch
361a26d690e6f1585c6710b3afeb10a6 acpid.patch
78bb1e70897124a0e09d50c425210e83 busybox-mkdir-permissions-64bit.patch
-058da9d0a595430e840e5793b5a5d059 0001-acpid-fix-for-clean-exit-on-SIGTERM.patch
-5ed72ca85b8fba4598d64a550210b31f busybox-1.19.3-getty.patch
-41636628e481f22b8774b6bee1eebfb1 busybox-1.19.3-modinfo.patch
-cb48bffc0e1e3be527cd4ff67324a2a2 busybox-1.19.3-wget.patch
-7c809b9cd30f40354be90663d5f18bef busybox-1.19.3-mdev.patch
+cfafb917f777437f428ea97da0a63915 0001-acpid-do-not-install-handlers-for-fatal-signals.patch
+699701047d05468a13e5c37b5ebc3824 0001-grep-support-for-x-match-whole-line.patch
42e2f49483e650193c0e142ade7de142 busyboxconfig"