aboutsummaryrefslogtreecommitdiffstats
path: root/main/bwm-ng/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/bwm-ng/APKBUILD')
-rw-r--r--main/bwm-ng/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/main/bwm-ng/APKBUILD b/main/bwm-ng/APKBUILD
new file mode 100644
index 0000000000..16ade39aac
--- /dev/null
+++ b/main/bwm-ng/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=bwm-ng
+pkgver=0.6
+pkgrel=2
+pkgdesc="A small and simple console-based live bandwidth monitor"
+url="http://www.gropp.org/"
+arch="all"
+license="GPL"
+subpackages="$pkgname-doc"
+depends=
+makedepends="ncurses-dev"
+source="http://www.gropp.org/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --with-libstatgrab \
+ --with-procnetdev \
+ --with-ncurses \
+ --with-partitions
+
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+
+}
+md5sums="d3a02484fb7946371bfb4e10927cebfb bwm-ng-0.6.tar.gz"