aboutsummaryrefslogtreecommitdiffstats
path: root/main/check/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/check/APKBUILD')
-rw-r--r--main/check/APKBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/main/check/APKBUILD b/main/check/APKBUILD
index 0a63738da2..39163b7329 100644
--- a/main/check/APKBUILD
+++ b/main/check/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=check
pkgver=0.12.0
-pkgrel=1
+pkgrel=2
pkgdesc="A unit test framework for C"
url="https://libcheck.github.io/check/"
arch="all"
@@ -12,20 +12,15 @@ checkdepends="diffutils gawk"
subpackages="$pkgname-doc $pkgname-dev"
source="https://github.com/libcheck/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
-
build() {
cd "$builddir"
- # NOTE: disabled forking due to hardened
- # https://github.com/libcheck/check/issues/138
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var \
- --disable-fork
+ --localstatedir=/var
make
}