aboutsummaryrefslogtreecommitdiffstats
path: root/main/check/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/check/APKBUILD')
-rw-r--r--main/check/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/main/check/APKBUILD b/main/check/APKBUILD
index b4a09cfa06..ad9506c80d 100644
--- a/main/check/APKBUILD
+++ b/main/check/APKBUILD
@@ -8,7 +8,10 @@ url="https://libcheck.github.io/check/"
arch="all"
license="LGPL2+"
makedepends="pkgconfig"
-subpackages="$pkgname-dev $pkgname-doc"
+# https://github.com/libcheck/check/issues/138
+options="!check"
+checkdepends="diffutils"
+subpackages="$pkgname-doc $pkgname-dev"
source="https://github.com/libcheck/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
@@ -25,6 +28,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install