aboutsummaryrefslogtreecommitdiffstats
path: root/main/claws-mail/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/claws-mail/APKBUILD')
-rw-r--r--main/claws-mail/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/main/claws-mail/APKBUILD b/main/claws-mail/APKBUILD
new file mode 100644
index 0000000000..5d133d7442
--- /dev/null
+++ b/main/claws-mail/APKBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=claws-mail
+pkgver=3.7.4
+pkgrel=0
+pkgdesc="A GTK+ based e-mail client."
+url="http://www.claws-mail.org"
+license="GPL3"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="gtk+-dev openssl-dev startup-notification-dev enchant-dev
+ libsm-dev gnutls-dev curl-dev dbus-glib-dev libetpan-dev openldap-dev"
+depends=
+# gpgme-dev libetpan-dev
+#pilot-link>=0.12.3-5
+install= #claws-mail.install
+source="http://downloads.sourceforge.net/sourceforge/sylpheed-claws/$pkgname-$pkgver.tar.bz2
+ libc-version.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ patch -p1 -i ../libc-version.patch || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --disable-static \
+ --enable-enchant \
+ --enable-gnutls \
+ --enable-ldap \
+ --disable-dillo-viewer-plugin \
+ --enable-crash-dialog \
+ --enable-pgpmime-plugin \
+ --enable-spamassassin-plugin \
+ --enable-bogofilter-plugin \
+ --disable-jpilot
+ make || return 1
+ cd tools
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ find tools -maxdepth 1 -type f -and -perm /111 -or -name '*.conf' | while read i; do
+ install -D -m755 ${i} "$pkgdir"/usr/lib/claws-mail/tools/${i}
+ done
+}
+md5sums="aa6c8b9177bc2bc506470821ee2afbb2 claws-mail-3.7.4.tar.bz2
+f3416743b5d8ff97b5a3cc2f7efc2dc1 libc-version.patch"