aboutsummaryrefslogtreecommitdiffstats
path: root/main/claws-mail/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/claws-mail/APKBUILD')
-rw-r--r--main/claws-mail/APKBUILD61
1 files changed, 61 insertions, 0 deletions
diff --git a/main/claws-mail/APKBUILD b/main/claws-mail/APKBUILD
new file mode 100644
index 0000000000..ce1e0d34d4
--- /dev/null
+++ b/main/claws-mail/APKBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=claws-mail
+pkgver=3.7.9
+pkgrel=2
+pkgdesc="A GTK+ based e-mail client."
+url="http://www.claws-mail.org"
+arch="all"
+license="GPL3"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="gtk+-dev openssl-dev startup-notification-dev enchant-dev
+ libsm-dev gnutls-dev curl-dev dbus-glib-dev libetpan-dev openldap-dev"
+depends=
+install=
+source="http://downloads.sourceforge.net/sourceforge/sylpheed-claws/$pkgname-$pkgver.tar.bz2
+ libc-version.patch
+ startup-notification-segfault.patch
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1 ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --disable-static \
+ --enable-enchant \
+ --enable-gnutls \
+ --enable-ldap \
+ --disable-dillo-viewer-plugin \
+ --disable-crash-dialog \
+ --enable-pgpmime-plugin \
+ --enable-spamassassin-plugin \
+ --enable-bogofilter-plugin \
+ --disable-jpilot \
+ || return 1
+
+ # force disabling of backtrace. the core dump was more useful
+ sed -i -e '/HAVE_BACKTRACE/d' config.h
+
+ make || return 1
+ cd tools
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ find tools -maxdepth 1 -type f -and -perm /111 -or -name '*.conf' | while read i; do
+ install -D -m755 ${i} "$pkgdir"/usr/lib/claws-mail/tools/${i}
+ done
+}
+md5sums="2f9d2dcabf84e312cfeb56efa799b5b3 claws-mail-3.7.9.tar.bz2
+f3416743b5d8ff97b5a3cc2f7efc2dc1 libc-version.patch
+1f0773ab009c966dd8b587422890247e startup-notification-segfault.patch"