aboutsummaryrefslogtreecommitdiffstats
path: root/main/cpufrequtils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/cpufrequtils/APKBUILD')
-rw-r--r--main/cpufrequtils/APKBUILD43
1 files changed, 33 insertions, 10 deletions
diff --git a/main/cpufrequtils/APKBUILD b/main/cpufrequtils/APKBUILD
index 01e33737e2..a4d73eddd0 100644
--- a/main/cpufrequtils/APKBUILD
+++ b/main/cpufrequtils/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cpufrequtils
pkgver=008
-pkgrel=2
+pkgrel=3
pkgdesc="Userspace tools for the kernel cpufreq subsystem"
url="http://www.kernel.org/pub/linux/utils/kernel/cpufreq/cpufrequtils.html"
arch="all"
@@ -10,18 +10,26 @@ subpackages="$pkgname-dev $pkgname-doc"
depends="sysfsutils"
makedepends="sysfsutils-dev libtool"
source="ftp://ftp.archlinux.org/other/cpufrequtils/cpufrequtils-$pkgver.tar.bz2
- cpufrequtils-006-nls.patch
- 0001-Support-for-Position-Independet-Code-by-aboid-clobbe.patch
+ 0001-Only-x86-has-cpuid-instruction.patch
+ 0002-cpufrequtils-Remove-proc-compile-option-and-interfac.patch
+ 0003-cpufrequtils-aperf-Fix-MSR-read-on-32-bit.patch
+ 0005-cpufrequtils-sysfs-increase-MAX_LINE_LEN.patch
+ 0006-aperf-fix-compilation-on-x86-32-with-fPIC.patch
+ 0007-po-add-missing-word-in-DE.patch
+ 0008-cpufrequtils-make-NLS-optional.patch
$pkgname.initd
$pkgname.confd"
-build() {
+prepare() {
cd "$srcdir"/$pkgname-$pkgver
for i in ../*.patch; do
msg "Applying $i..."
patch -p1 < $i || return 1
done
+}
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
# distcc and ccache makes libtool confused about the tag.
# we save 4k by disabling the 2.4 kernel support (PROC=false)
make -j1 LIBTOOL_OPT="--tag=CC --silent" \
@@ -42,17 +50,32 @@ package() {
}
md5sums="c59b71c044d463896f3247e8dd83dd7e cpufrequtils-008.tar.bz2
-aa4c6f19766a741a68ae1ad352c6bad9 cpufrequtils-006-nls.patch
-9f999b70138d84580894df48340e50cc 0001-Support-for-Position-Independet-Code-by-aboid-clobbe.patch
+9ed71a50670aa99e12245cb3f5199142 0001-Only-x86-has-cpuid-instruction.patch
+4ccbd46b0b1563067d0c31fe510ff89d 0002-cpufrequtils-Remove-proc-compile-option-and-interfac.patch
+5dd9add84e63b213295e2e2a30fd3667 0003-cpufrequtils-aperf-Fix-MSR-read-on-32-bit.patch
+139b340b964e2c942dbe426b061c6bc8 0005-cpufrequtils-sysfs-increase-MAX_LINE_LEN.patch
+2242f015ca6b8478d6c1a3bfbca5ea48 0006-aperf-fix-compilation-on-x86-32-with-fPIC.patch
+0b7d50274fa8286796c9df0b156e2962 0007-po-add-missing-word-in-DE.patch
+a99653aab0d334569496a402389f062f 0008-cpufrequtils-make-NLS-optional.patch
b9b80ef2f1b6c5e7ce0476037a8bce6b cpufrequtils.initd
d47ff635eef03248c633486eaeec191d cpufrequtils.confd"
sha256sums="1b9daa591d977679fb09ffb9b4d58afa94b9387f3c0be92ec077080e328130f1 cpufrequtils-008.tar.bz2
-fb60cf2543461af3f47ea85927be5d5242489da99a32801ed8beea65a21472b4 cpufrequtils-006-nls.patch
-3501d2e07ed7a7609d93d40428057935a08cb84f7b46882710d6b4cf966c1749 0001-Support-for-Position-Independet-Code-by-aboid-clobbe.patch
+6793e7e330fe6c9125c998011f203a4d8d5887872178fc872861db1d5dce55ef 0001-Only-x86-has-cpuid-instruction.patch
+62efd52ea004e1974a09cc5646fbc18d47b372a54ed33361fb2c8470bd931501 0002-cpufrequtils-Remove-proc-compile-option-and-interfac.patch
+5ef9bae9272f867c0187ba0b4845888cf6bb567a4a242da5001b3a4a05935a2c 0003-cpufrequtils-aperf-Fix-MSR-read-on-32-bit.patch
+76038bb0197d02c91b7dfde5e65cab9379526bba02cb2bab751bbf23a63b392e 0005-cpufrequtils-sysfs-increase-MAX_LINE_LEN.patch
+99b2b04301f1656ea263e5d693be701be8af40880747fd3e34c9c27e5540eefa 0006-aperf-fix-compilation-on-x86-32-with-fPIC.patch
+245f1c9db3f8120eb014f782476df6a38c22700dd438d532943ad35f4e4ca46d 0007-po-add-missing-word-in-DE.patch
+bb1cba04abb42843085ea4f2b38d539cfe7d4db93ffaca453891ee2de6c6feac 0008-cpufrequtils-make-NLS-optional.patch
af83b2354bd8876efecd85762a61a40a4b498633e186cb85db7a22389936a2e6 cpufrequtils.initd
602b65f6e9927bfb37a26a34c1b44bd4a87cdb2977b5547398e17432afe55727 cpufrequtils.confd"
sha512sums="d25dcc4fbf15bdca65a3fab6ee33d6cf4b7ab7ed291aea42ed7970b707535ddfcd27fd0189aa48affc2792abf72539f1388cc544019e6fc06353a2f9c5a49d17 cpufrequtils-008.tar.bz2
-26e2c9e273b084eb64b38b187064a560d05479026522912390054fdbc99eaba55ca682a59884bc67f013c3ce9d7b80e5ba765351765d921c0c66573287f1db52 cpufrequtils-006-nls.patch
-827e9b73902f50c9bce75b76cd33759a627837705dc92520ab360e95cc9b242a76c5d59cd9eea83cd6d2c832b97f74f3e3ac31f3bfef82d36fa0a55266e7ec72 0001-Support-for-Position-Independet-Code-by-aboid-clobbe.patch
+4d841bdf2b829518932505747e68d661219337259c1321cdd6671faf2eb72ff6d7f437e42b98f093f9d6564d2bb7be1d4ab645f08b0fbd58ce43339a12be37da 0001-Only-x86-has-cpuid-instruction.patch
+6d8c6beb98d680d4d47c5cc0a067545b1683f259b7d2474a61876b5e97987be30b8d212017122157236ae91bd415793e5f5a0d22214bfc3f2ec72cf626d28832 0002-cpufrequtils-Remove-proc-compile-option-and-interfac.patch
+41082f5ed4cc2962927b12b8dcf4b0dadf6fb227b66b8f383931c7ae0416fa5f73e765664376b50e07948e48060770a7d32bc7422b144c0cb82166515e197f9b 0003-cpufrequtils-aperf-Fix-MSR-read-on-32-bit.patch
+00fb946b1f0b42038297b9cf63740a4123a4aafa5292400225803ef8cd6f1e89b387509c2f74fa6223b3b2b3032b6e0edcbfc3b6bf15aab73bb480c0208330b9 0005-cpufrequtils-sysfs-increase-MAX_LINE_LEN.patch
+7e924424fe3381fd804edfcb0c0c98e73b67e4da7972c7cfe0bc9cfb5febd2ec660f4e84b6bebe2b0b6d2dc5e60279ebe85d1892905b1112ee43d60b46bcdef5 0006-aperf-fix-compilation-on-x86-32-with-fPIC.patch
+69343ab9c9b795523bcd09359f4acdb279510a95c6aa13f70be1d0e2e89ed59952a34f979969f6a3ac3498ad7196ee1c810677fe2d04c5f02207682b820b97bb 0007-po-add-missing-word-in-DE.patch
+5d5eab9815d77b8ae9c6c9d122f52da7501068b9a6fe7766e74a8f59d1296c0bcb6e5a61a643e371e2e1433912d48205c8f522207144bb02a3c9961043eb968b 0008-cpufrequtils-make-NLS-optional.patch
a9a1023ad5d55b9050a392a8c05e29dbf1ed9bcdcd8e82063d38adc2a81a86e306ffd7aaf048518a1ca427b4ffcd0ca9410fbd5ae5defe648512e81366caecaa cpufrequtils.initd
81adc035c781c2c6f94fdb9a69dfb5d867830ab0685f2badce055b9f8095881456522fc0cd5386140d920fd1d9b96c82d8dcecd9962e3e6ef5f9be926153802b cpufrequtils.confd"