aboutsummaryrefslogtreecommitdiffstats
path: root/main/cryptsetup
diff options
context:
space:
mode:
Diffstat (limited to 'main/cryptsetup')
-rw-r--r--main/cryptsetup/APKBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/main/cryptsetup/APKBUILD b/main/cryptsetup/APKBUILD
index 0d6c99fb5b..fb96f1dac9 100644
--- a/main/cryptsetup/APKBUILD
+++ b/main/cryptsetup/APKBUILD
@@ -6,12 +6,14 @@ pkgrel=0
pkgdesc="Userspace setup tool for transparent encryption of block devices using the Linux 2.6 cryptoapi"
url="https://gitlab.com/cryptsetup/cryptsetup"
arch="all"
+options="!checkroot"
license="GPL-2.0-or-later"
depends=""
makedepends_build=""
makedepends_host="lvm2-dev libressl-dev popt-dev util-linux-dev
json-c-dev argon2-dev"
makedepends="$makedepends_build $makedepends_host"
+checkdepends="device-mapper sharutils which"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
source="https://www.kernel.org/pub/linux/utils/$pkgname/v${pkgver%.*}/$pkgname-$pkgver.tar.gz
flush-stdout.patch
@@ -34,6 +36,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR=$pkgdir install