aboutsummaryrefslogtreecommitdiffstats
path: root/main/cvs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/cvs/APKBUILD')
-rw-r--r--main/cvs/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/main/cvs/APKBUILD b/main/cvs/APKBUILD
new file mode 100644
index 0000000000..03c7b8f55c
--- /dev/null
+++ b/main/cvs/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=cvs
+pkgver=1.12.13
+pkgrel=1
+pkgdesc="Concurrent Versions System"
+url="http://www.nongnu.org/cvs/"
+arch="all"
+license="GPL"
+depends=""
+makedepends="zlib-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://ftp.gnu.org/non-gnu/cvs/source/feature/$pkgver/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-external-zlib \
+ --with-tmpdir=/tmp \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+md5sums="7a71a2e7a64973ecf255965956a1d338 cvs-1.12.13.tar.gz"