aboutsummaryrefslogtreecommitdiffstats
path: root/main/dahdi-linux/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/dahdi-linux/APKBUILD')
-rw-r--r--main/dahdi-linux/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/main/dahdi-linux/APKBUILD b/main/dahdi-linux/APKBUILD
new file mode 100644
index 0000000000..632851ee13
--- /dev/null
+++ b/main/dahdi-linux/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Timo Teras <timo.teras@iki.fi>
+# Maintainer: Timo Teras <timo.teras@iki.fi>
+
+pkgname=dahdi-linux
+pkgver=2.4.1.2
+pkgrel=0
+pkgdesc="Firmware for Digium Asterisk Hardware Device Interface drivers"
+url="http://www.asterisk.org"
+arch="all"
+license="GPL"
+depends=
+# we need wget and tar because make install downloads firmware and uses fancy
+# options for tar and wget.
+makedepends="wget tar"
+install=
+subpackages="$pkgname-dev"
+source="http://downloads.digium.com/pub/telephony/dahdi-linux/releases/$pkgname-$pkgver.tar.gz"
+
+# We online install the firmwares in this package since those are common for all
+# kernel flavors. We also install the headers for the -dev package.
+#
+# The kernel drivers themselves are built from separate build recipe.
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in ../*.patch ../*.diff; do
+ [ -f "$i" ] || continue
+ msg "Applying $i"
+ patch -p1 < $i || return 1;
+ done
+}
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" HOTPLUG_FIRMWARE=yes \
+ install-include install-firmware
+}
+
+md5sums="81b232a47693f4adac90c569e446f88f dahdi-linux-2.4.1.2.tar.gz"