aboutsummaryrefslogtreecommitdiffstats
path: root/main/db/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/db/APKBUILD')
-rw-r--r--main/db/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/main/db/APKBUILD b/main/db/APKBUILD
index d1c333e854..725aff033b 100644
--- a/main/db/APKBUILD
+++ b/main/db/APKBUILD
@@ -15,8 +15,14 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-utils $pkgname-c++:cxx"
source="http://download.oracle.com/berkeley-db/db-$pkgver.tar.gz
"
+_builddir="$srcdir/db-$_ver"
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build () {
- cd "$srcdir"/db-$_ver
+ cd "$_builddir"
for i in ../patch.*; do
[ -r "$i" ] || continue
msg "Applying $i..."