aboutsummaryrefslogtreecommitdiffstats
path: root/main/db/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/db/APKBUILD')
-rw-r--r--main/db/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/db/APKBUILD b/main/db/APKBUILD
index 2da5fde9e9..d1c333e854 100644
--- a/main/db/APKBUILD
+++ b/main/db/APKBUILD
@@ -24,12 +24,16 @@ build () {
done
cd build_unix
- ../dist/configure --prefix=/usr \
+ ../dist/configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
--mandir=/usr/share/man \
--enable-compat185 \
--enable-shared \
--enable-cxx \
- --disable-static
+ --disable-static \
+ || return 1
make LIBSO_LIBS=-lpthread || return 1
}