aboutsummaryrefslogtreecommitdiffstats
path: root/main/drbd-utils/busybox-mv.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/drbd-utils/busybox-mv.patch')
-rw-r--r--main/drbd-utils/busybox-mv.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/main/drbd-utils/busybox-mv.patch b/main/drbd-utils/busybox-mv.patch
new file mode 100644
index 0000000000..74fc9faa1c
--- /dev/null
+++ b/main/drbd-utils/busybox-mv.patch
@@ -0,0 +1,13 @@
+diff --git a/user/shared/Makefile.in b/user/shared/Makefile.in
+index 8b8be16..3240089 100644
+--- a/user/shared/Makefile.in
++++ b/user/shared/Makefile.in
+@@ -84,7 +84,7 @@ drbd_buildtag.c:
+ grep return $@ ; \
+ fi ; \
+ echo -e "\t\t\" build by $$USER@$$HOSTNAME, `date "+%F %T"`\";\n}"; \
+- mv --force $@.new $@
++ mv -f $@.new $@
+
+ drbdmeta_scanner.c: drbdmeta_scanner.fl drbdmeta_parser.h
+ flex -s -odrbdmeta_scanner.c drbdmeta_scanner.fl