aboutsummaryrefslogtreecommitdiffstats
path: root/main/etckeeper/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/etckeeper/APKBUILD')
-rw-r--r--main/etckeeper/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/main/etckeeper/APKBUILD b/main/etckeeper/APKBUILD
new file mode 100644
index 0000000000..ba1ce6a68c
--- /dev/null
+++ b/main/etckeeper/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
+# Maintainer: Henrik Riomar <henrik.riomar@gmail.com>
+
+pkgname=etckeeper
+pkgver=1.18.12
+pkgrel=1
+pkgdesc="Store /etc in git."
+url="http://etckeeper.branchable.com"
+arch="noarch"
+license="GPL-2.0-or-later"
+checkdepends="bats fakeroot"
+depends="findutils git"
+subpackages="$pkgname-doc"
+options="!checkroot"
+install="$pkgname.post-install $pkgname.pre-deinstall"
+source="$pkgname-$pkgver.tar.gz::https://git.joeyh.name/index.cgi/etckeeper.git/snapshot/etckeeper-$pkgver.tar.gz
+ apk-commit_hook
+ "
+
+prepare() {
+ default_prepare
+
+ sed -i 's|^PYTHON=python$|PYTHON=/bin/false|' Makefile
+ sed -i 's/_PACKAGE_MANAGER=.*/_PACKAGE_MANAGER=apk/' etckeeper.conf
+}
+
+check() {
+ make test
+}
+
+package() {
+ make install DESTDIR="$pkgdir"
+ rm -rf "$pkgdir"/lib/systemd
+ rmdir "$pkgdir"/lib/
+ rm -rf "$pkgdir"/etc/apt
+
+ install -m755 -D "$builddir"/debian/cron.daily \
+ "$pkgdir"/etc/periodic/daily/"$pkgname"
+
+ install -m755 -D "$srcdir"/apk-commit_hook \
+ "$pkgdir"/etc/apk/commit_hooks.d/"$pkgname"
+}
+
+sha512sums="7fb75d89bbf69d5ef29fc93f34f8368f0d93adb6f89a96be4769be4a58faff793682f5a5fc6f6f2bf51bc5a151a28b61319396a4298cbf0aa75ff3c1bbb660d7 etckeeper-1.18.12.tar.gz
+d0ff88615359e8b03da5f9162a7bae3f32c06891a8899096025283d77e950dd72280c6c19b8eb8a4cde08742c6ca715cd32c37c16e8bbf2d030e9fd16a1fc940 apk-commit_hook"