aboutsummaryrefslogtreecommitdiffstats
path: root/main/file/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/file/APKBUILD')
-rw-r--r--main/file/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/main/file/APKBUILD b/main/file/APKBUILD
index 27d4c1367a..92cd07968d 100644
--- a/main/file/APKBUILD
+++ b/main/file/APKBUILD
@@ -10,8 +10,15 @@ depends=
source="ftp://ftp.astron.com/pub/file/file-$pkgver.tar.gz"
subpackages="$pkgname-dev $pkgname-doc"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \