aboutsummaryrefslogtreecommitdiffstats
path: root/main/fontconfig/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/fontconfig/APKBUILD')
-rw-r--r--main/fontconfig/APKBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/main/fontconfig/APKBUILD b/main/fontconfig/APKBUILD
index 7bf0409f7f..22cafba9a3 100644
--- a/main/fontconfig/APKBUILD
+++ b/main/fontconfig/APKBUILD
@@ -2,15 +2,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fontconfig
pkgver=2.13.1
-pkgrel=1
+pkgrel=2
pkgdesc="Library for configuring and customizing font access"
url="https://www.freedesktop.org/wiki/Software/fontconfig"
arch="all"
license="MIT"
makedepends="freetype-dev expat-dev python3-dev gperf util-linux-dev"
triggers="$pkgname.trigger=/usr/share/fonts/*"
-subpackages="$pkgname-doc $pkgname-dev"
-source="http://fontconfig.org/release/${pkgname}-${pkgver}.tar.gz"
+subpackages="$pkgname-static $pkgname-dev"
+source="http://fontconfig.org/release/fontconfig-$pkgver.tar.gz"
+
+replaces="fontconfig-doc" # Package removed as license is no longer provided
build() {
cd "$builddir"
@@ -25,8 +27,7 @@ build() {
--localstatedir=/var \
--enable-static \
--disable-nls \
- --disable-docs \
- --disable-static
+ --disable-docs
rm -f src/fcobjhash.h
make
}
@@ -39,8 +40,6 @@ check() {
package() {
cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
-
- install -m644 -D COPYING "$pkgdir"/usr/share/licenses/"${pkgname}"/COPYING
}
sha512sums="830df32e944ee21ad02a9df04787b9902af36ffc13913524acef6e38799a38c5df7a6e407cc0ff9c24455520549d53b3d85d22642a229ac654dc9269926f130b fontconfig-2.13.1.tar.gz"